can't update on non-administrator ( user ) account

RESOLVED DUPLICATE of bug 407875

Status

()

defect
RESOLVED DUPLICATE of bug 407875
11 years ago
11 years ago

People

(Reporter: pinochet.pl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 1.1.4322; FDM)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

FF tries to update even it is already up to date. When updated by another user.


Reproducible: Always

Steps to Reproduce:
1. Create non-administrator ( user ) account in win XP
2. Install previos version of FF 3.0.1 ( on administrator account )
3. Run FF on user account and let it auto-update itself
4. Close FF
5. Run FF once again on user account

Actual Results:  
Firefox starts the auto updater application. Auto updater try(there is the progres bar) to change files  in paths where user haven't privileges to change files so update fails. Then application shows alert (I'm using polish version so I don't now how it exactly is in english ) "Update fails, Make sure other copy of FF is not runing, next run again FF for update." 

Alert has only OK button. !!!

After push it, FF starts autamatically again, and behaviour described above repeats. So FF falls to endless loop.

Update on administrator account go ahead without troubles, but even after it my FF runing on user account want's to update (in way described above).


Expected Results:  
1. Check is update necessary ( another user could done it yet )
Or:
2. Show the alert for log in as admin - and continue process ( It would be the best solution)
Or:
3. At least stops runing after OK ;-)
Version: unspecified → 3.0 Branch
Component: Shell Integration → Application Update
Product: Firefox → Toolkit
QA Contact: shell.integration → application.update
Version: 3.0 Branch → unspecified
This is covered by a couple of other bugs already filed. Duping to the one that is covered by the expected results.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407875
You need to log in before you can comment on or make changes to this bug.