Drag and drop ical (.ics) attachments onto calendar icon does nothing

VERIFIED FIXED in 1.0b1

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: maxxmozilla, Assigned: dbo)

Tracking

({regression})

unspecified
1.0b1
regression
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b1pre) Gecko/20081004 Lightning/1.0pre Shredder/3.0b1pre ID:20081004031302

Drag and drop ical (.ics) attachments onto calendar / tasks icon does nothing.

Reproducible: Always

Steps to Reproduce:
1. Drag and drop ical (.ics) attachment onto calendar / tasks icon.
Actual Results:  
Nothing happens.

Expected Results:  
New event / task creation.

Error: [Exception... "Could not convert JavaScript argument arg 0 [nsIUnicharStreamLoader.init]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://calendar/content/calendar-dnd-listener.js :: calDNDDrop :: line 324"  data: no]
Source File: chrome://calendar/content/calendar-dnd-listener.js
Line: 326
(Reporter)

Updated

10 years ago
Keywords: regression
(Assignee)

Comment 1

10 years ago
Works for me on Mac.
Keywords: qawanted

Comment 2

10 years ago
I checked this issue on Linux and Windows and I get the exception too.
Confirmed using Lightning 1.0pre (ID: 20081007031722) and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081007 Shredder/3.0b1pre (ID: 20081007031514).
Could this be related to the landing of the new Drag&Drop API (http://developer.mozilla.org/en/DragDrop/Drag_and_Drop)?
(Assignee)

Comment 5

10 years ago
Created attachment 342227 [details] [diff] [review]
fix - v1

I can reproduce it now.

It seems to be an incompatible change on trunk.
Assignee: nobody → daniel.boelzle
Attachment #342227 - Flags: review?(mschroeder)
(Assignee)

Updated

10 years ago
Keywords: qawanted
(Assignee)

Comment 6

10 years ago
Created attachment 342230 [details] [diff] [review]
fix - v2

- fixing missing calendar for item, too
Attachment #342227 - Attachment is obsolete: true
Attachment #342230 - Flags: review?(mschroeder)
Attachment #342227 - Flags: review?(mschroeder)
Status: NEW → ASSIGNED
Comment on attachment 342230 [details] [diff] [review]
fix - v2

r=mschroeder
Attachment #342230 - Flags: review?(mschroeder) → review+
(Assignee)

Comment 8

10 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a0784e1ef1fc>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 9

10 years ago
> -> FIXED
I've tried to verify on manually patched latest build but since a few builds drag and drop to calendar / tasks new icons is not allowed and this patch didn't changed it so it's a little hard to verify ;) -> reopening or new bug ?
(Assignee)

Comment 10

10 years ago
Christian has set up bug 459641.
(Reporter)

Comment 11

10 years ago
Thanks.
I've applied the patch to the latest build with the "classic" calendar toolbar (build 20081008091054) and I still can't verify the fix ?
(bug 459641 would unlock drop action but if this bug is not really fixed then not much would change)

Error: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://calendar/content/calendar-dnd-listener.js :: calDNDDrop :: line 325"  data: no]
Source File: chrome://calendar/content/calendar-dnd-listener.js
Line: 328
(Assignee)

Comment 12

10 years ago
The fix has worked for me on Mac at that time, dragging an iTIP attachment onto the mode buttons. Maybe you're dragging something else? Please give some more details, especially your platform.
(Assignee)

Comment 13

10 years ago
I keep this bug open and recheck the fix once bug 459641 is fixed.
Severity: minor → normal
Status: RESOLVED → REOPENED
Depends on: 459641
Flags: blocking-calendar1.0+
Resolution: FIXED → ---
(Reporter)

Comment 14

10 years ago
I don't know what kind of problems you had with confirming this bug at the beginning but regarding my comment 11 it was - let's say broken e-mail...

-> Verifying as fixed (if it would be broken after bug 459641 is fixed then it would be a different bug)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081014 Lightning (patched build 20081007031722)/1.0pre Shredder/3.0b1pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081014 Lightning (patched build 20081007032648)/1.0pre Shredder/3.0b1pre
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
No longer depends on: 459641
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

10 years ago
For those interested:
I will not be filing bug against lightning regarding comment 11 error (invite.ics attachment was detached and removed from the file system) because I should be thankful Bug 292385

> Maybe you're dragging something else?
yeah, attachment that isn't there and so NS_ERROR_FILE_NOT_FOUND ;)
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.