Clicking links with text-decoration: blink doesn't always work

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
2 months ago

People

(Reporter: martijn.martijn, Assigned: tnikkel)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Posted file testcase
See testcase, when clicking on the link, it doesn't work when the text is invisible, only when the text is visible.
This regressed somewhere between Firefox 2 and Firefox 3.
(Reporter)

Updated

11 years ago
works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060125 Firefox/1.6a1 ID:2006012505
fails:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012609

=> range:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-01-25+04%3A00&maxdate=2006-01-26+10%3A00&cvsroot=%2Fcvsroot

(this was painful finding since the 1.6a builds of those days crashed on https sites for me -> got to save the testcase locally ...)
Probably bug 317375
(Reporter)

Updated

10 years ago
Blocks: 317375
(Assignee)

Comment 3

10 years ago
Posted patch patchSplinter Review
I do not know why I am fixing this.

I couldn't find any spec saying anything about taking or not taking a click when the text is invisible. So I don't know if we want to do this or not.
Assignee: nobody → tnikkel
Attachment #382253 - Flags: superreview?(roc)
Attachment #382253 - Flags: review?(roc)
Comment on attachment 382253 [details] [diff] [review]
patch

Why not!
Attachment #382253 - Flags: superreview?(roc)
Attachment #382253 - Flags: superreview+
Attachment #382253 - Flags: review?(roc)
Attachment #382253 - Flags: review+
If you can't find anything more interesting than this to do, we should talk :-)
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

10 years ago
(In reply to comment #5)
> If you can't find anything more interesting than this to do, we should talk :-)

I'll try to catch you online tomorrow, or ping me when it's a good time for you.
(Reporter)

Comment 7

10 years ago
(In reply to comment #5)
> If you can't find anything more interesting than this to do, we should talk :-)

All the bugs I file are very interesting!
Timothy, please, feel free to continue fixing them!
http://hg.mozilla.org/mozilla-central/rev/d7b4504ea75c
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.