".part" is not removed when download is finished, preventing me from opening the file in another program easily

VERIFIED DUPLICATE of bug 475008

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 475008
10 years ago
9 years ago

People

(Reporter: strayan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

Downloads get appended with ".part". Since some files are created on the fly, it looks like Firefox doesn't know that the download is finished, so it names it blahblah.pls.part [for instance], which prevents it from being opened [in this case by iTunes; as it is a pls file].

Reproducible: Always

Steps to Reproduce:
Unknown.
Actual Results:  
Downloaded file is appended with .part even though it's a completed download.

Expected Results:  
Not append the file with .part

Most easily replicated by installing the http://userscripts.org/scripts/show/1820 userscript which generates an m3u playlist from .mp3 links on a web page and is then opened in your media player.

Updated

10 years ago
Component: General → Download Manager
Product: Firefox → Toolkit
QA Contact: general → download.manager
Summary: Downloads get appended with ".part" which prevents downloads being opened by other programs → ".part" is not removed when download is finished, preventing me from opening the file in another program easily
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475008
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.