crash loading flash plugin

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: waterson, Assigned: pavlov)

Tracking

({crash, platform-parity})

Trunk
x86
Linux
crash, platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I was tinkering around with a test case, and am crashing in GTK with the test 
case I'm about to attach. To reproduce:

1. Download the shockwave flash plugin for Linux. You can get it at 
http://www.macromedia.com/, click on the "Download Free Flash Player" link.

2. Install it in the $(DIST)/bin/plugins directory. You only need to install 
the file "libflashplayer.so"; the other stuff is unnecessary.

3. Try to load the attached test case. In a debug build, you'll get the 
following messages, and then the process aborts:

Inside nsPluginHostImpl::FindStoppedPluginForURL...
debug: edburns ns4xPlugin::CreatePlugin
debug: edburns ns4xPlugin::CreatePlugin: cleared callbacks
debug: edburns: ns4xPlugin::CreatePlugin: callbacks->newstream: 0x41f59380
Inside ns4xPluginInstance::Start(void)...
Inside ns4xPluginInstance::SetWindow(0x847c2fc)...
About to create new ws_info...
About to create new xtbin of 604 X 308 from 0x83fe528...
About to show xtbin(0x83fea78)...
completed gtk_widget_show(0x83fea78)
About to call CallNPP_SetWindowProc()...
Falling out of ns4xPluginInstance::SetWindow()...
created stream for http://www.macromedia.com/hommie_v11.swf
InstantiateEmbededPlugin.. returning
Inside ns4xPluginInstance::SetWindow(0x847c2fc)...
About to call CallNPP_SetWindowProc()...
Falling out of ns4xPluginInstance::SetWindow()...
Inside ns4xPluginInstance::SetWindow(0x847c2fc)...
About to create new ws_info...
About to create new xtbin of 604 X 308 from 0x83fe528...
About to show xtbin(0x845adc8)...
completed gtk_widget_show(0x845adc8)
About to call CallNPP_SetWindowProc()...
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 43 error_code 9 request_code 72 minor_code 0

Program exited with code 01.
(gdb) 

pavlov: av said I should assign this to you. Sorry! (By the way, the flash 
plugin seems to work fine when loaded from Macromedia's site.)
(Reporter)

Updated

19 years ago
Keywords: crash, pp
(Reporter)

Comment 1

19 years ago
Created attachment 11579 [details]
test case
(Assignee)

Comment 2

19 years ago
I already fixed this

*** This bug has been marked as a duplicate of 37477 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

19 years ago
No, you didn't.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

19 years ago
He really..really fixed this (linux build 2000072508). Chris, I see no crash 
upon loading your testcase on rdht linux 6.1 with today's build.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
waterson just ran it on his machine fine.

Comment 6

19 years ago
let's close this. VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.