Last Comment Bug 458703 - gcc warning: nsWindow.cpp:5804: warning: unused variable ‘gtk_xim_context_class’
: gcc warning: nsWindow.cpp:5804: warning: unused variable ‘gtk_xim_context_class’
Status: RESOLVED FIXED
[build_warning]
: inputmethod
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 520732
Blocks: 458491
  Show dependency treegraph
 
Reported: 2008-10-06 06:48 PDT by georgi - hopefully not receiving bugspam
Modified: 2011-07-09 05:09 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description georgi - hopefully not receiving bugspam 2008-10-06 06:48:29 PDT
+++ This bug was initially created as a clone of Bug #458491 +++


probably the fix will be deleting stuff.
Comment 1 Ed Morley [:emorley] 2011-07-09 05:09:40 PDT
The line in question was moved to /widget/src/gtk2/nsGtkIMModule.cpp in bug 520732, where the unused variable warning was suppressed, since it was needed to prevent the XIM module from being unloaded and reloaded each time.

Note You need to log in before you can comment on or make changes to this bug.