migration dialog not launched on first run

RESOLVED WORKSFORME

Status

()

Firefox
Migration
P3
normal
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: juanb, Assigned: mossop)

Tracking

({relnote})

Trunk
x86
Windows XP
relnote
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

While testing litmus test case 5909, the migration dialog does not come up on first run (no existing profile).

STR:

1. Make sure you you remove any existing Firefox profiles (http://kb.mozillazine.org/Profile_folder#Firefox)
2. Install Fx3.1b1 and launch it

Expected: On launch you should see the migration dialog come up, which allows you to import settings from other browsers

Actual: No migration dialog comes up.
Flags: blocking-firefox3.1?
(Reporter)

Comment 1

9 years ago
I don't get this problem on reference QA virtual machine (Vista), nor a personal XP vm. So this could be a problem with our XP virtual machine.

Comment 2

9 years ago
Confirmed on Vista Business also, that there is no migration dialog on firstrun install for beta 1.  I'm not using a Virtual Machine either, but a full installation.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1) Gecko/20081007
Firefox/3.1b1

Recommending we relnote this for beta 1.
Keywords: relnote
(Reporter)

Comment 3

9 years ago
I checked on a Vista Business installation on hardware and I don't see the problem there either.
(Reporter)

Comment 4

9 years ago
tchung was actually using a Vista Home Basic; but I confirm that the migration wizard does not come up when following the steps in the original description.
Confirmed on Vista Home Premium (didn't think it would be different from Basic)
so same result as juanb

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
Flags: blocking-firefox3.1? → blocking-firefox3.1+
(Assignee)

Updated

9 years ago
Assignee: nobody → dtownsend
(Assignee)

Comment 6

9 years ago
I cannot reproduce this and litmus shows that people have been running and passing this testcase. Are there some other steps to reproduce this?

Setting the priority as it seems to be working, can raise it if there is a common way to trigger this.
Priority: -- → P3
It's been a while, but I think this will depend on what you're deleting.  If you delete profiles.ini, does it work?  What if you delete the parent folder?  One of those is what the migration wizard is checking, IIRC.
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> It's been a while, but I think this will depend on what you're deleting.  If
> you delete profiles.ini, does it work?  What if you delete the parent folder? 
> One of those is what the migration wizard is checking, IIRC.

I've tested with the profile folder itself deleted, with the parent of that (profiles) deleted, with the profiles.ini file deleted and with the parent of that (firefox) deleted. I also tested with 3.1b1 (what the bug was filed with) and the latest mozilla-central build. In the cases where profiles.ini or the firefox folder were deleted I saw the migration wizard. In the other cases firefox displays an error about firefox already running (bug 459082).

Comment 9

9 years ago
I only have Windows XP VM here at home, and was unable to reproduce this using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2.   I'll try again with my original scenario on vista on monday.

Juanb, can you still repro this?
(Reporter)

Comment 10

9 years ago
I cannot reproduce this problem on he latest nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081212 Shiretoko/3.1b3pre), using the October 20th clean XP VM snapshot from the QA directory on fs.

I tried installing, then uninstalling and using the option to remove the associated profile, and installing again. The migration wizard comes up.

Comment 11

9 years ago
I was able to reproduce the problem as well. I'm using windows xp professional service pack 2.

I uninstalled all my mozilla firefox browsers and started fresh with the 3.1 Beta 1 and didn't get the migration dialog box. I then repeated the same steps and uninstalled everything again and started fresh with firefox 3.1 Beta 2 and did not get prompted with the migration dialog box.
(Assignee)

Comment 12

9 years ago
(In reply to comment #11)
> I was able to reproduce the problem as well. I'm using windows xp professional
> service pack 2.

Everyone else is saying they cannot reproduce it.

> I uninstalled all my mozilla firefox browsers and started fresh with the 3.1
> Beta 1 and didn't get the migration dialog box. I then repeated the same steps
> and uninstalled everything again and started fresh with firefox 3.1 Beta 2 and
> did not get prompted with the migration dialog box.

When you uninstalled did you tick the option to remove your profile data. If not then you should not have seen the migration dialog

Comment 13

9 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > I was able to reproduce the problem as well. I'm using windows xp professional
> > service pack 2.
> 
> Everyone else is saying they cannot reproduce it.
> 
> > I uninstalled all my mozilla firefox browsers and started fresh with the 3.1
> > Beta 1 and didn't get the migration dialog box. I then repeated the same steps
> > and uninstalled everything again and started fresh with firefox 3.1 Beta 2 and
> > did not get prompted with the migration dialog box.
> 
> When you uninstalled did you tick the option to remove your profile data. If
> not then you should not have seen the migration dialog

For ff 3.1 beta 1 and ff 3.1 beta 2. I uninstalled using the option to remove profile data. I even made sure that all profiles were deleted by going to 'run' %application% and deleting the profiles manually.. Upon re-launch I was still unable to produce the 'migration dialog prompt'
Until we can get steps to reproduce here, I don't think we can consider this anything more than a unique (but crappy, sorry!) issue to grayskies. To him I'd suggest scouring the HDD for cruft that may have existed that's causing this ... remember that some user directory data can get bifurcated if you've had various and sundry sync or backup software running, and maybe we're tripping on that?

Still, the comments from QA and the passing Litmus tests give me confidence that we're not seeing a problem that affects 99% of our users here, so RESO WFM. If we can get a solid reason to re-open, this will again pick up blocking.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
@grayskies: you'd actually have to run %appdata% to get to the profile, maybe that's why you were able to reproduce.

Comment 16

9 years ago
(In reply to comment #15)
> @grayskies: you'd actually have to run %appdata% to get to the profile, maybe
> that's why you were able to reproduce.

I actually was running %appdata%. I apologize for my mistake on what I said earlier. I don't know why I typed %application%, when I was actually typing in %appdata%
Just to note, I see the same problem now while release testing Firefox 3.5 beta 4. Check bug 490009 for more information.
You need to log in before you can comment on or make changes to this bug.