Closed Bug 459107 Opened 14 years ago Closed 14 years ago

Sunbird startup error (NS_ERROR_FILE_NOT_FOUND - nsIXPCComponents_Utils.import)

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: dbo)

Details

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081008 Sunbird/1.0pre

Sunbird doesn't start correctly. View is empty and no default calendar is available. Bug filed as unconfirmed due to the lack of a official nightly build for verification. Error Console shows: 

Warning: Warning: Duplicate resource declaration for 'calendar' ignored.
Source file: file:///E:/obj/sb/mozilla/dist/bin/chrome/calendar.manifest
Line: 5

Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source file: file:///E:/obj/sb/mozilla/dist/bin/components/calItemModule.js -> file:///E:/obj/sb/mozilla/dist/bin/js/calIcsParser.js
Line: 38

Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source file: chrome://calendar/content/calendar-ui-utils.js
Line: 49

Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source file: chrome://calendar/content/calendar-unifinder.js
Line: 56

Error: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source file: chrome://calendar/content/calUtils.js
Line: 173

Error: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source file: chrome://calendar/content/calUtils.js
Line: 155

Error: redeclaration of const SUNBIRD_UID
Source file: file:///E:/obj/sb/mozilla/dist/bin/components/calItemModule.js -> file:///E:/obj/sb/mozilla/dist/bin/js/calCalendarManager.js
Line: 41

Error: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source file: file:///E:/obj/sb/mozilla/dist/bin/components/calCompositeCalendar.js -> file:///E:/obj/sb/mozilla/dist/bin/js/calUtils.js
Line: 155
Same error using official tinderbox build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081008 Calendar/1.0pre (BuildID: 20081008224113).
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch fix - v1Splinter Review
Since some component scripts are loaded prior to chrome (due to app-startup), we need to manually register our alias. I will file a separate bug regarding the trailing slash workaround.
Assignee: nobody → daniel.boelzle
Attachment #342400 - Flags: review?(philipp)
(In reply to comment #2)
> Since some component scripts are loaded prior to chrome (due to app-startup),
There's bug 457596 already filed for this.

> we need to manually register our alias. I will file a separate bug regarding
> the trailing slash workaround.
filed bug 459196
Comment on attachment 342400 [details] [diff] [review]
fix - v1

>+        if (spec[spec.length - 1] == '/') {
>+            // we need to cut/hack around the trailing slash, otherwise our modules won't be found
>+            // when loaded like "resource://calendar/modules/calUtils.jsm"; bug will be filed
>+            modulesUri.spec = spec.substr(0, spec.length - 1);
>+        }

spec = spec.replace(/\/$/, "");

Unless already filed, I'd love to see a core bug to allow module definition parsing from chrome.manifest to happen earlier.
Attachment #342400 - Flags: review?(philipp) → review+
> (From update of attachment 342400 [details] [diff] [review])
> spec = spec.replace(/\/$/, "");
done

> Unless already filed, I'd love to see a core bug to allow module definition
> parsing from chrome.manifest to happen earlier.
see comment #3, bug 459196


Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/38cb09a53f4c>

-> FIXED(In reply to comment #4)
Status: NEW → RESOLVED
Closed: 14 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081010 Calendar/1.0pre (BuildID: 20081010073800).
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.