Exception in (NS_ERROR_INVALID_POINTER) [nsIPermissionManager.add] failure blocking images from Page Info

VERIFIED FIXED in Firefox 3.1b2

Status

()

Firefox
Page Info Window
--
blocker
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression, verified1.9.1})

Trunk
Firefox 3.1b2
regression, verified1.9.1
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [to be fixed by 458579])

(Reporter)

Description

9 years ago
Seen while testing  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1.

STR:
1. Run https://litmus.mozilla.org/show_test.cgi?id=6478
2. Images are not blocked for that page and I get an error in the console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIPermissionManager.add]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://browser/content/pageinfo/permissions.js :: onRadioClick :: line 127"  data: no]

I get the same error message when I try to block cookies and it doesn't seem to be holding the radio button selection that I make.
OS: Mac OS X → All
Hardware: PC → All

Comment 1

9 years ago
I can repro this on linux as well.  Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

It seems that all the other options under Permissions do not persist the "Allow" radio checkbox after closing the window  (load images, open popups, set cookies, install extensions)

This seems to be a regression, as it works on Fx3.0.3.   Need to find the range.
Severity: critical → blocker
Flags: blocking-firefox3.1?
This is caused by bug 458579 and will be fixed by the patch there.
Depends on: 458579
(Reporter)

Comment 3

9 years ago
here is the short regression range:

Works in Mac Build ID=20081007020454
Does not work: BuildID=20081008040822
No longer depends on: 458579
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Whiteboard: [to be fixed by 458579]

Comment 4

9 years ago
Fixed by bug 458579, the test in https://litmus.mozilla.org/show_test.cgi?id=6478
works now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Target Milestone: --- → Firefox 3.1b2

Comment 5

9 years ago
marking verified for Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081013 Minefield/3.1b2pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1

Updated

9 years ago
Keywords: verified1.9.1
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.