session restore dialog appears after a system reboot when it shouldn't

RESOLVED DUPLICATE of bug 336193

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 336193
10 years ago
a year ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

in ubuntu 8, I have 3.1b5 installed and running a few tabs.  I reboot the system using "sudo shutdown -r now" and when it comes back up and I launch firefox again, it prompts me with the question to restore my previous session.  This is not the correct behavior and doesn't work this way on windows.

Reproducible: Always

Steps to Reproduce:
1. launch firefox with a couple tabs
2. reboot os
3. launch firefox
Actual Results:  
you see the session restore message 

Expected Results:  
just launch firefox without session restore

Comment 1

10 years ago
Yeah, Firefox isn't closed properly when using "shutdown". Session Restore does the right thing under these circumstances, though. You rather want bug 336193 being fixed:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 336193
You need to log in before you can comment on or make changes to this bug.