Closed Bug 459352 Opened 11 years ago Closed 11 years ago

No progress bar in '% complete' column

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: andreas.treumann, Assigned: Fallen)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- open the task mode
- create a task with 50% progress
- add the '% complete' column

RESULT:
=======

- there is no progress bar '% complete' column visible  

EXPECTED RESULT:
================

- a progress bar should be visible.
 
REPRODUCIBLE:
=============

- always
I'd like to see this in 1.0, this shouldn't be that hard to achieve. Markus, maybe you can take a look?
Flags: wanted-calendar1.0+
Assignee: nobody → MarkusAdrario
Debugging showed the following:
The Treecol is of type Progressmeter [1] but the meter is not shown.

The function getCellValue [2] which is responsible to set the Value of the Progressmeter is not executed. (verified with a dump statement inside).

Since this could be because the type of the treecol does not get set correctly I tried to put a dump() in getProgressMode function [3] which is as well only called for PM-cells. This time the dump() was executed.
--> the type of the treecol is set correctly.

In the Syntax of the getCellValue function seems to be no error.

Since the Value is not set, the Progressmeter is not displayed.

Question is now: Why is the function not executed?

[1]: treecol type statement
http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-task-tree.xml#113

[2]: function getCellValue
http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-task-tree.xml#601

[3]: function getProgressMode
http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-task-tree.xml#689
Attached patch Fix - v1 β€” β€” Splinter Review
I found the culprit: when a column is of type progressmeter, the getProgressMode function of the treeview is asked, what kind of progressmeter it should be. It seems we changed the case of the "itemproperty" attribute somewhere and forgot to also change the value in the tree view.
Assignee: Mozilla → philipp
Status: NEW → ASSIGNED
Attachment #378042 - Flags: review?(Mozilla)
Attachment #378042 - Flags: review?(Mozilla) → review+
Comment on attachment 378042 [details] [diff] [review]
Fix - v1

Works Fine - Progressmeters are back in Task Mode and Today-Pane if you make the column wide enough.

r=Markus
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/c6f398d078e7>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.