Closed Bug 459358 Opened 14 years ago Closed 14 years ago

It is possible to attempt to create new cards/lists in read-only address books.

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

Go to the address book, select New Card, in the drop down menu, select a LDAP or Mac OS X address book, fill in the card, select OK.

The address book attempts to write a new card in the LDAP/Mac OS X address book.

In the mac case, clicking on ok just fails (the dialog stays on the screen). In the LDAP case we will attempt to write to the directory, there will be no feedback if it fails, and a card may appear in the display indicating it may have been added.

The problem is the new card/list dialogs have an incorrectly spelled attribute set.
Attached patch The fixSplinter Review
Fix wrong spelling and hence make the attribute work.
Attachment #342560 - Flags: superreview?(bienvenu)
Attachment #342560 - Flags: review?(bienvenu)
Attachment #342560 - Flags: superreview?(bienvenu)
Attachment #342560 - Flags: superreview+
Attachment #342560 - Flags: review?(bienvenu)
Attachment #342560 - Flags: review+
Checked in, changeset id 584:773da60a6113
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
You need to log in before you can comment on or make changes to this bug.