Closed Bug 459508 Opened 13 years ago Closed 13 years ago

Images scaling is using nearest neighbour algorithm on Linux

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 422179

People

(Reporter: e.a.b.piel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008092903 Mandriva/1.9.0.3-1mdv2009.0 (2009.0) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008092903 Mandriva/1.9.0.3-1mdv2009.0 (2009.0) Firefox/3.0.3

On windows and mac, the images are rescaled using a nice looking algorithm (bilinear or bicubic) when the page is zoomed in. However, on Linux the pictures become very ugly. It's very easy to verify, for instance go to google.com, zoom in one level: the letters of the pictures have lots of small "edges".

This is documented in the code, in  gfx/src/thebes/nsThebesImage.cpp:  599         // See bug 324698.  This is a workaround for EXTEND_PAD not being
600         // implemented correctly on linux in the X server.

However, since release 1.6, cairo does support CAIRO_EXTEND_PAD correctly:
http://www.cairographics.org/news/cairo-1.6.0/

So this workaround for Linux should be removed.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422179
You need to log in before you can comment on or make changes to this bug.