Closed Bug 459531 Opened 11 years ago Closed 10 years ago

Firefox sometimes crashes on ehsan's blog [@ libobjc.A.dylib@0x15688][@ gfxAtsuiFont::GetCharWidth]

Categories

(Core :: Graphics, defect, critical)

1.9.0 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4pre) Gecko/2008100504 GranParadiso/3.0.4pre ID:2008100504

I don't have real STR until now but sometimes Firefox crashes when opening http://ehsanakhgari.org. I wasn't able to reproduce this issue on trunk.

crash report: bp-8b15d7b0-9792-11dd-9016-001cc45a2c28

0  	libobjc.A.dylib  	libobjc.A.dylib@0x15688  	
1 	ATS 	ATS@0x18294 	
2 	QD 	QD@0x81ce 	
3 	QD 	QD@0x1e0e8 	
4 	QD 	QD@0x1debc 	
5 	QD 	QD@0x1d612 	
6 	QD 	QD@0x2f28e 	
7 	QD 	QD@0x39e98 	
8 	QD 	QD@0x39dc9 	
9 	XUL 	gfxAtsuiFont::GetCharWidth 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:330
10 	XUL 	gfxAtsuiFont::InitMetrics 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:282
11 	XUL 	gfxAtsuiFont::gfxAtsuiFont 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:117
12 	XUL 	GetOrMakeFont 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:449
13 	XUL 	gfxAtsuiFontGroup::FindATSUFont 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:523
14 	XUL 	gfxFontGroup::FontResolverProc 	mozilla/gfx/thebes/src/gfxFont.cpp:919
15 	XUL 	gfxPlatformMac::ResolveFontName 	mozilla/gfx/thebes/src/gfxPlatformMac.cpp:181
16 	XUL 	gfxFontGroup::ForEachFontInternal 	mozilla/gfx/thebes/src/gfxFont.cpp:886
17 	XUL 	gfxFontGroup::ForEachFont 	mozilla/gfx/thebes/src/gfxFont.cpp:762
18 	XUL 	gfxAtsuiFontGroup::gfxAtsuiFontGroup 	mozilla/gfx/thebes/src/gfxAtsuiFonts.cpp:468
19 	XUL 	gfxPlatformMac::CreateFontGroup 	mozilla/gfx/thebes/src/gfxPlatformMac.cpp:196
20 	XUL 	nsThebesFontMetrics::Init 	mozilla/gfx/src/thebes/nsThebesFontMetrics.cpp:89
21 	XUL 	nsFontCache::GetMetricsFor 	mozilla/gfx/src/nsDeviceContext.cpp:500
22 	XUL 	nsLayoutUtils::GetFontMetricsForStyleContext 	mozilla/layout/base/nsLayoutUtils.cpp:1304
23 	XUL 	nsHTMLReflowState::CalcLineHeight 	mozilla/layout/generic/nsHTMLReflowState.cpp:2058
24 	XUL 	nsBlockReflowState::nsBlockReflowState 	mozilla/layout/generic/nsBlockReflowState.cpp:428
25 	XUL 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:925
26 	XUL 	nsBlockReflowContext::ReflowBlock 	mozilla/layout/generic/nsBlockReflowContext.cpp:311
27 	XUL 	nsBlockFrame::ReflowBlockFrame 	mozilla/layout/generic/nsBlockFrame.cpp:2978
28 	XUL 	nsBlockFrame::ReflowLine 	mozilla/layout/generic/nsBlockFrame.cpp:2250
29 	XUL 	nsBlockFrame::ReflowDirtyLines 	mozilla/layout/generic/nsBlockFrame.cpp:1886
30 	XUL 	nsBlockFrame::Reflow 	mozilla/layout/generic/nsBlockFrame.cpp:953
31 	XUL 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
32 	XUL 	CanvasFrame::Reflow 	mozilla/layout/generic/nsHTMLFrame.cpp:584
33 	XUL 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
34 	XUL 	nsHTMLScrollFrame::ReflowScrolledFrame 	mozilla/layout/generic/nsGfxScrollFrame.cpp:499
35 	XUL 	nsHTMLScrollFrame::ReflowContents 	mozilla/layout/generic/nsGfxScrollFrame.cpp:593
36 	XUL 	nsHTMLScrollFrame::Reflow 	mozilla/layout/generic/nsGfxScrollFrame.cpp:794
37 	XUL 	nsContainerFrame::ReflowChild 	mozilla/layout/generic/nsContainerFrame.cpp:771
38 	XUL 	ViewportFrame::Reflow 	mozilla/layout/generic/nsViewportFrame.cpp:286
39 	XUL 	PresShell::DoReflow 	mozilla/layout/base/nsPresShell.cpp:6280
40 	XUL 	PresShell::ProcessReflowCommands 	mozilla/layout/base/nsPresShell.cpp:6386
41 	XUL 	PresShell::DoFlushPendingNotifications 	mozilla/layout/base/nsPresShell.cpp:4574
42 	XUL 	PresShell::ReflowEvent::Run 	mozilla/layout/base/nsPresShell.cpp:6145
43 	XUL 	nsThread::ProcessNextEvent 	mozilla/xpcom/threads/nsThread.cpp:510
44 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:180
45 	XUL 	nsBaseAppShell::NativeEventCallback 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:121
46 	XUL 	nsAppShell::ProcessGeckoEvents 	mozilla/widget/src/cocoa/nsAppShell.mm:302
47 	CoreFoundation 	CoreFoundation@0x72614 	
48 	CoreFoundation 	CoreFoundation@0x72cf7 	
49 	HIToolbox 	HIToolbox@0x2f47f 	
50 	HIToolbox 	HIToolbox@0x2f1d1 	
51 	HIToolbox 	HIToolbox@0x2f10c 	
52 	AppKit 	AppKit@0x403ec 	
53 	AppKit 	AppKit@0x3fc9f 	
54 	AppKit 	AppKit@0x38cda 	
55 	XUL 	nsAppShell::Run 	mozilla/widget/src/cocoa/nsAppShell.mm:591
56 	XUL 	nsAppStartup::Run 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:181
57 	XUL 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3174
58 	firefox-bin 	main 	mozilla/browser/app/nsBrowserApp.cpp:158
59 	firefox-bin 	start 	crt.c:272
60 	firefox-bin 	start 	
61 		@0x0
Henrik, can you validate your fonts with Font Book?  If you have any fonts that aren't stock Mac OS X fonts, it's possible one of them is corrupt and was hit here.  (Bug 459711 has a very similar stack and seems to be caused by a corrupt font.)
Smokey, I've checked all the installed fonts and each of them is valid. So it cannot belong to a corrupted font. Even the crash doesn't happen at any time. I had it twice when testing it but no idea how to reproduce it regularly.
Without a reduced testcase, other people able to reproduce, or access to the code in question, this is unlikely to be fixed.  Especially since it sounds like it only affects 3.0.x.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
Summary: Firefox sometimes crashes when opening url [@ libobjc.A.dylib@0x15688][@ gfxAtsuiFont::GetCharWidth] → Firefox sometimes crashes on ehsan's blog [@ libobjc.A.dylib@0x15688][@ gfxAtsuiFont::GetCharWidth]
(Btw, how did you make sure your fonts were "valid"?  See e.g. bug 459711.)
I guess 459711 comment 29 sorta answers my question.
Didn't happen anymore since I have been reported the crash. It's more WFM.
Resolution: INCOMPLETE → WORKSFORME
I think this was resolved by bug 476504, we check for errors fetching horizontal metrics before reaching the code that in this case crashes.

Has anyone experienced this crash after February, when bug 476504 was checked in?
Crash Signature: [@ libobjc.A.dylib@0x15688] [@ gfxAtsuiFont::GetCharWidth]
You need to log in before you can comment on or make changes to this bug.