Page specific error console

RESOLVED DUPLICATE of bug 386138

Status

Toolkit Graveyard
Error Console
--
enhancement
RESOLVED DUPLICATE of bug 386138
9 years ago
2 years ago

People

(Reporter: stenorman2001, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

When attempting to debug Javascript, the Error Console has proven to be an invaluable resource. What would be nice however is if you could link the error console to a particular page, so that you could be debugging multiple pages at the same time, without having each pages errors mix together in the console.

This could be done by having a pane at the bottom of each page that could be opened and used, then closed when your finished. This would be best described as a similar feature to the integrated Web Inspector that appears in WebKit. It can exist as a panel at the bottom of the page as well as a window. The pane at the bottom of the page could simply be a filter for the error console, filtering only errors relevent to the page you are on.

While there are numerous web developer tools that can be added as addons the integrated error console in Firefox is extremely powerful but could be extended to provide far greater flexibility to casual and even professional developers.

Reproducible: Always

Updated

9 years ago
Component: General → Error Console
Product: Firefox → Toolkit
QA Contact: general → error.console
Duplicate of this bug: 527656

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386138
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.