Closed Bug 459748 Opened 13 years ago Closed 13 years ago

Characters badly layout for printing

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 403513

People

(Reporter: gandrusz, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092816 Iceweasel/3.0.3 (Debian-3.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092816 Iceweasel/3.0.3 (Debian-3.0.3-2)

After clicking on the print icon and printing (either to actual printer, or pdf) the characters are layout incorrectly - some are too close to each other, some are too far. The same thing works perfectly well in Windows.

Reproducible: Always

Steps to Reproduce:
1.Open the web page
2.Click on printer symbol
3.Print
Actual Results:  
the characters are layout incorrectly - some are too close to each other, some are too far

Expected Results:  
Look at the windows version
Confirming bug.  Print output from Firefox 2 (on Linux) looks much better.
Status: UNCONFIRMED → NEW
Component: General → Printing: Output
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → printing
I can also confirm the bug. Especially when I print http://de.wikipedia.org/wiki/Saudade with Arial 14pt as standard font selected ("Edit"/"Preferences", "Content" tab).

The problem appears already in the print preview and is exactly reproduced on the printouts and also when printing into PostScript or PDF files. So the problem is not in the printing system or the printer driver. It is in the rendering of the pages for the print function of Firefox.

I use Firefox 3.0.3, shipped with the released Ubuntu Intrepid (8.10) on an x86_64 system.
Note, to get Arial on the mentioned Ubuntu distribution, you must install the msttcorefonts package from Multiverse.
Depends on: 403513
Component: Printing: Output → GFX: Thebes
QA Contact: printing → thebes
Version: unspecified → Trunk
This looks the same as bug 403513.
Status: NEW → RESOLVED
Closed: 13 years ago
No longer depends on: 403513
Resolution: --- → DUPLICATE
Duplicate of bug: 403513
You need to log in before you can comment on or make changes to this bug.