Button on Flickr page not working (Javascript error?)

RESOLVED DUPLICATE of bug 539488

Status

()

RESOLVED DUPLICATE of bug 539488
10 years ago
9 years ago

People

(Reporter: paul.0000.black, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b2pre) Gecko/20081015 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b2pre) Gecko/20081015 Minefield/3.1b2pre

On a Flickr photo page such as http://www.flickr.com/photos/sat9/2566991655 there is an "All Sizes" button just above the photo. Clicking this produces no action (should go to another page). Middle clicking or right clicking and opening in another tab/window works fine.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.flickr.com/photos/sat9/2566991655
2. Click on "All Sizes" button

Actual Results:  
Browser should go to another page.

Expected Results:  
The button is depressed indicating it's been pressed but nothing else happens.

I've checked the previous couple of nightlies and they're the same. 3.1b1 doesn't exhibit this problem. Also occurs with the nightly on Windows.

Comment 1

10 years ago
Also the Organize function does not work. 
Step to reproduce is:
http://www.flickr.com/photos/organize/

Error message is:
TypeError: F.eb_add is not a function
Would you like to reload the page?

I used:
Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2pre) Gecko/20081015 SeaMonkey/2.0a2pre

Mac OS 10.4.11

Comment 2

10 years ago
My reported bug is for SeaMonkey not Firefox. I forgot to emphasize this.
Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US;
rv:1.9.1b2pre) Gecko/20081015 SeaMonkey/2.0a2pre

Comment 3

10 years ago
I experienced this too on Firefox. However, with the current nightly it is working fine.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081016 Minefield/3.1b2pre ID:20081016033525

Comment 4

10 years ago
Fixed too on latest SeaMonkey build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081016 SeaMonkey/2.0a2pre
(Reporter)

Comment 5

10 years ago
Also looking good on the nightly Firefox for 64 bit Linux.

Comment 6

9 years ago
I am having these symptoms on the current 64-bit Firefox nightly.

Comment 7

9 years ago
I'm seeing something very much like this in recent 32-bit nightlies on Win32.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: unspecified → Trunk

Comment 8

9 years ago
I broke |var undefined;| in the global scope (or rather, my change activated the functionality that caused it to break).  The next TM merge should include the fix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539488
You need to log in before you can comment on or make changes to this bug.