Event handlers on INS element are not working

VERIFIED DUPLICATE of bug 62160

Status

()

P3
major
VERIFIED DUPLICATE of bug 62160
18 years ago
18 years ago

People

(Reporter: marcell, Assigned: joki)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The INS HTML element should support the following 10 event handlers, onclick, 
ondblclick, onmousedown, onmouseup, onmouseover, onmousemove, onmouseout, 
onkeypress, onkeydown, onkeyup. In Mozilla, none of these event handlers work on 
the INS element.

REPRODUCTABILITY: Every time

STEPS TO REPRODUCE: 
1. Open attachment in Mozilla.
2. Perform the events stated on each INS element.

ACTUAL RESULTS: The event handler was not triggered; nothing happened.The event 
handler was not triggered; nothing happened.

EXPECTED RESULTS: The event handler should have been triggered and should have 
popped up an alert.
(Reporter)

Comment 1

18 years ago
Created attachment 11644 [details]
Testcase

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P3 → P2
There is a similar bug for DEL. See bug 46030.

Comment 3

18 years ago
Inserted text elements require event handling support for HTML 4.0 
compliance. Nominating for beta2.
Keywords: nsbeta2
I think you got this bug wrong, gerardok. It is not about inserted text
elements. This bug is about the HTML INS element (I think this is extremely
rare, I was not even aware of such an element before this bug). The INS element
is used to mark modifications to the original document, in this case insertions.
There is a similar element called DEL which is for deleted content.

I removed the nsbeta2 keyword.
Keywords: nsbeta2
keypress, keyup, keydown events should not work on INS element, see bug 46042.
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 7

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 8

18 years ago
Marking INVALID per Heikki's comments in bug #46042:

"------- Additional Comments From Heikki Toivonen 2000-07-25 15:35 -------

After talking with vidur@netscape.com, it is our opinion that only focusable
content should respond to keypress etc. events. tt, and the majority of HTML
elements are not focusable content (unfortunately the HTML spec just assigns all
intrinsic attributes to just about every element even when they make no sense).
Painting the element with mouse does not make the element focused.

Marking INVALID."
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
Marking VERIFIED INVALID on:
- LinuxRH62 2000-08-22-06-M18 Commercial
- Win98     2000-08-22-08-M18 Commercial
- MacOS86   2000-08-21-08-M18 Commercial
Status: RESOLVED → VERIFIED
Uh, only the three events I mentioned should not work. Others should work, 
therefore this bug is valid. Reopening.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 11

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
This was fixed by jst's fix to bug 62160. So this and bug 46003 are actually
duplicates of the one jst fixed. The bug was that the content sink created wrong
kinds of elements when it saw DEL or INS element. This even resulted in crash later!

Marking duplicate.


*** This bug has been marked as a duplicate of 62160 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 13

18 years ago
From the comments above, and also the fact that this stuff seems to work properly 
in Mac OS Build 01-04-08 (and it didn't before:)):

VERIFIED.

And I didn't even mark this one FIXED, either:).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.