update <video> control icons

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Toolkit
Video/Audio Controls
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: skierpage, Assigned: Boriss)

Tracking

({polish, verified1.9.1})

unspecified
mozilla1.9.2a1
polish, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-visual][polish-p2], URL)

Attachments

(5 attachments, 7 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081015 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081015 Minefield/3.1b2pre ID:20081015032107

The images for the video controls, e.g. on http://www.double.co.nz/video_test/events.html, should be improved to match the accepted iconography of audio equipment.

Reproducible: Always

Steps to Reproduce:
1. Go to a page with video controls, or view chrome://global/skin/media/videocontrols.png
2. Run a screen magnifier like Windows' magnify.exe

Actual Results:  
The pause bars are slightly too tall.

The volume control speaker isn’t quite right, the voice coil on the back has rounded back corners (a voice coil has a squared off edge) and the coil is slightly too big for that size cone.



I earlier provided this feedback on http://jboriss.wordpress.com/2008/09/19/html-5-video-tag-pirate-edition/#comment-318 , along with comments on other parts of the control UI that aren't exposed (yet?).
(Reporter)

Comment 1

10 years ago
I adjusted the pause and the voice coil in http://www.skierpage.com/moz_bugs/videocontrols_tweaked.png , go back/forwards between it and chrome://global/skin/media/videocontrols.png to see the improvements.

Unfortunately, #$@! MS Paint changed the color balance (what tool do you use to edit PNGs?), so it's not a replacement.
(Assignee)

Comment 2

10 years ago
Thanks for the feedback, skierpage.  I'll revisit this & post a mockup here.
(Reporter)

Updated

9 years ago
Keywords: polish
Whiteboard: [polish-easy]
Assignee: nobody → jboriss
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 3

9 years ago
Created attachment 353402 [details]
Orginal patched indiced with the changes described in comment #0
Attachment #353402 - Flags: review?(dolske)

Comment 4

9 years ago
Created attachment 353426 [details]
Centered pauze button

Pauze button was not centered, moved 1px to the left to make it centered.
Attachment #353402 - Attachment is obsolete: true
Attachment #353426 - Flags: review?(dolske)
Attachment #353402 - Flags: review?(dolske)
Comment on attachment 353426 [details]
Centered pauze button

It basically looks fine to me, but...

* Bug 464371 is spitting these into multiple PNGs (1 per button state).

* If we're going to clean these up, I'd also like to make them proper transparent images (ie, transparent background instead of dark gray).

Boriss, I assume you have original vector art for these buttons? Can you generate cleaned up versions with all these changes?
Attachment #353426 - Flags: review?(dolske) → review-

Updated

9 years ago
Blocks: 470629

Comment 6

9 years ago
Ok, understood. That will be much better.

Comment 7

9 years ago
Created attachment 355399 [details]
Another example of fixed & transparent mediaplayer buttons.

Bug 464371 has split the image into four images, but didn't fix the issue of this bug. 
Btw, why split the image into separate images per button?
-moz-image-region was invented for the purpose of reducing the number of images in chrome (as they do impact performance of the browser overall).

Updated

9 years ago
Attachment #355399 - Attachment description: Another example of fixed mediaplayer → Another example of fixed & transparent mediaplayer buttons.
(In reply to comment #7)

> Btw, why split the image into separate images per button?
> -moz-image-region was invented for the purpose of reducing the number of images
> in chrome (as they do impact performance of the browser overall).

Because -moz-image-region doesn't work with background images.

Comment 9

9 years ago
But as the buttons are now real xul buttons, a normal list-style-image would also work. And for making the background grey, background-color:grey would work ;-).

As said in other comments, the preference is to use transparent icons, and let the css do the styling... 

Note, I have done with my themes (such as Nautipolis and Walnut) and this works like a charm, with the added benefit that the browser provided controlBar as the same styling as the browser itself.
Sure, but the purpose of bug 464371 was suppress the unexpected load events. For example:

<button onload="alert('load')" style="list-style-image: url(http://www.google.com/intl/en_ALL/images/logo.gif)"/>

When <video onload="..."> gets triggered because of these image loads events, that's a problem.

Comment 11

9 years ago
So list-style-image do cause load events, but background-image not?
(Assignee)

Comment 12

9 years ago
Created attachment 355872 [details]
preview of video controls: slightly larger, glyphs different, opacity added

I agree with the jist of Comment 1, but would go a bit further.  I've posted new versions of the graphics, with some changes:

- Pause icon a better height/thickness ratio
- Colors of played/loaded/unloaded more distinct from each other
- Volume icon looks less like shuttlecock

- Colors and opacities of controls and background changed to look better on various backgrounds.  I've been playing around with this and think that a better solution than having the full opacity of the controls on top of the video is to have parts of it slightly transparent, so that some of the video can be seen below it.  This makes the controls more visually integrated - rather than something stamped on top of the video, something blended in.  If the background especially can be made slightly transparent, the difference is pretty striking (see preview).
(Assignee)

Comment 13

9 years ago
Created attachment 355873 [details]
.zip file of graphic elements in preview version
(Assignee)

Comment 14

9 years ago
Created attachment 355878 [details]
muted glyph - speaker w/no sound wave

pleaze to be provided
(Assignee)

Comment 15

9 years ago
Created attachment 355880 [details]
same icons in 24x24 boxen
(Assignee)

Updated

9 years ago
Attachment #355878 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Attachment #355873 - Attachment is obsolete: true
(Assignee)

Comment 16

9 years ago
Created attachment 355889 [details]
the muted button moved to the left slightly, so it lines up with non-muted speaker
Created attachment 355898 [details] [diff] [review]
Patch v.1

Patch version of Boriss's icon update.
Attachment #353426 - Attachment is obsolete: true
Attachment #355399 - Attachment is obsolete: true
Attachment #355880 - Attachment is obsolete: true
Attachment #355889 - Attachment is obsolete: true
Attachment #355898 - Flags: ui-review?(faaborg)
Attachment #355898 - Attachment is patch: true
Attachment #355898 - Attachment mime type: application/octet-stream → text/plain
Created attachment 355900 [details]
Screencap of Patch v.1
Attachment #355898 - Flags: ui-review?(faaborg) → ui-review+
There are some gray lines on the inside edges of the pause button.  I'm not sure if this was intentional or not, and not a big enough deal to block ui-r+, but they might make the icon look ever so slightly fuzzy.
Summary: in <video> controls, the pause control is too tall and loudspeaker looks wrong → update <video> control icons
Attachment #355898 - Flags: approval1.9.1?
Comment on attachment 355898 [details] [diff] [review]
Patch v.1

a191=beltzner
Attachment #355898 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 21

9 years ago
Created attachment 356278 [details]
same icons in 28x28
Pushed http://hg.mozilla.org/mozilla-central/rev/c2fae3249064
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
(Assignee)

Comment 24

9 years ago
Created attachment 356837 [details]
Play button moved one pixel to the right
Verified on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090313 Shiretoko/3.1b4pre Ubiquity/0.1.5
and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090313 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
This bug's priority relative to the set of other polish bugs is:
P2 - Polish issue that is in a secondary interface, occasionally encountered, and is easily identifiable.
Whiteboard: [polish-easy] → [polish-easy][polish-visual][polish-p2]
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Target Milestone: mozilla1.9.2a1 → ---
Version: Trunk → unspecified
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.