set journal_mode to TRUNCATE

RESOLVED FIXED in mozilla1.9.1b2

Status

()

RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: sdwilsh, Assigned: sdwilsh)

Tracking

Trunk
mozilla1.9.1b2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

985 bytes, text/plain
dietrich
: review+
samuel.sidler+old
: approval1.9.0.5-
Details
(Assignee)

Description

10 years ago
In order to upgrade SQLite, we need to set places journal_mode to TRUNCATE so we do not regress Ts on Linux.
(Assignee)

Comment 1

10 years ago
Created attachment 343423 [details]
v1.0
Attachment #343423 - Flags: review?(dietrich)
Attachment #343423 - Attachment mime type: application/octet-stream → text/plain
Attachment #343423 - Flags: review?(dietrich) → review+
(Assignee)

Comment 2

10 years ago
http://hg.mozilla.org/mozilla-central/rev/9753ccf72819
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
No longer blocks: 449443
(Assignee)

Updated

10 years ago
Duplicate of this bug: 457577
Looks like this has caused an increase in leak on:
WINNT 5.2 mozilla-central leak test build
Before:  195kb  After:  242kb
OS X 10.5.2 mozilla-central leak test build 
Before:  2.14mb after 2.19
(Assignee)

Comment 5

10 years ago
I think you are looking for bug 457158 and not this
Why would you point me to a month old bug when I saw the increase starting with the checkin of this bug ? 

The build with changeset 
http://hg.mozilla.org//mozilla-central/index.cgi/rev/a3fe1c305946 was 195kb,

the build just before the checkin of this bug, changeset:
http://hg.mozilla.org//mozilla-central/index.cgi/rev/9753ccf72819 
and the count went to 242kb and has stayed around that number for every build following.  

It may not be this exact bug, but it certainly didn't happen a month ago.  I am only posting what I see looking at the numbers in the waterfall tree - and trying to prevent another lengthy tree closure looking for why/when the leaks increased.
(Assignee)

Comment 7

10 years ago
I pointed you at that because I pushed this bug *along* with the SQLite upgrade, which is what caused that increase last time too...
(Assignee)

Updated

10 years ago
Blocks: 449443
(Assignee)

Comment 8

10 years ago
Comment on attachment 343423 [details]
v1.0

If we take bug 449443, we'll need this.
Attachment #343423 - Flags: approval1.9.0.5?
Comment on attachment 343423 [details]
v1.0

Approved for 1.9.0.5, a=dveditz for release-drivers
Attachment #343423 - Flags: approval1.9.0.5? → approval1.9.0.5+
(Assignee)

Updated

10 years ago
Depends on: 464299
(Assignee)

Comment 10

10 years ago
Checking in toolkit/components/places/src/nsNavHistory.cpp;
new revision: 1.307; previous revision: 1.306
Keywords: fixed1.9.0.5
(Assignee)

Comment 11

10 years ago
This was backed out due to a possible dataloss regression.

Checking in toolkit/components/places/src/nsNavHistory.cpp;
new revision: 1.308; previous revision: 1.307
Keywords: fixed1.9.0.5
Attachment #343423 - Flags: approval1.9.0.5+ → approval1.9.0.5-
You need to log in before you can comment on or make changes to this bug.