Should Clear Private Data include permission manager lists?

RESOLVED DUPLICATE of bug 380852

Status

()

RESOLVED DUPLICATE of bug 380852
10 years ago
4 years ago

People

(Reporter: johnath, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
From discussion with mconnor and faaborg, the question came up about whether CPD dialog should have a checkbox for permission manager entries, since it's an unexpected way for Firefox to still remember sites you've visited.

Language could be something like:

[ ] Site-specific Settings

or

[ ] Site-specific permissions

or

[ ] Saved settings for sites

Comment 1

10 years ago
I think if we choose to enable clearing permission manager entries in this dialog, we should also handle the permission manager in private browsing as well (in order to be consistent, at least).   The implementation would be simple, and I can file a follow-up to track this if needed.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> I think if we choose to enable clearing permission manager entries in this
> dialog, we should also handle the permission manager in private browsing as
> well (in order to be consistent, at least).   The implementation would be
> simple, and I can file a follow-up to track this if needed.

mconnor - what do you think?  You've been looking more in-depth at the PBM stuff than I have...
I don't think we should be aiming for a 1:1 mapping between private browsing and CPD.  Since we've made the decision that explicit actions (like changing prefs in the prefwindow) will be remembered, it doesn't make sense to clear some subset of what you can set in the prefwindow.  As with passwords, we should simply not ask users in the course of browsing (i.e. hide the "always for this site" UI for popups et al).  Messing with the backend will result in less predictable/consistent UI in some places (i.e. do we need to account for deletions?)

Let's not conflate the two, if we should not ask about saving some permissions, let's do that as well in a separate bug, but one does not automatically mean we need to address the other.

Comment 4

10 years ago
OK, filed bug 461625 to track which parts of the UI we need to hide for not saving permissions inside the private mode.

Also, filed bug 461627 in order to decide whether we need to hide the UI for permanent storage of certificate exceptions inside the corresponding dialog.  This _may_ also be worth thinking about for CPD as well (not sure if there is already a bug filed for it).
This got implemented in bug 380852 AFAICT.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380852
You need to log in before you can comment on or make changes to this bug.