Closed Bug 460413 Opened 11 years ago Closed 11 years ago

incorrect mail when accepting invitations with line breaks in subject

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 0.9
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: firefox, Assigned: dbo)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.5.30729)
Build Identifier: Lightning 0.9

When accepting an invitation containing newline characters in the subject line 
(e.g. created by Lotus Notes), the response mail is incorrect: 
It uses the complete invitation subject in the mail subject, including the 
newline characters (thereby creating new mail header lines). 

When the invitation subject ends with a newline character, this behaviour 
leads to a \n\n in the mail header, so that the remaining header lines are seen 
as message body.

Example: 
---------------------------------
MIME-version: 1.0
From: <me@....>
To: <him@.....>
Subject: Antwort Termineinladung: Multiline
Summary
Test

Content-type: multipart/mixed; boundary="Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)"


--Boundary_(ID_qyG4ZdjoAsiZ+Jo19dCbWQ)
Content-type: multipart/alternative;
 boundary="Boundary_(ID_ryU4ZdJoASiZ+Jo21dCbwA)"

[...]
----------------------------------------------------

Reproducible: Always

Steps to Reproduce:
1. Send an invitation with multiline subject (not possible in Lightning), 
   preferably ending with a newline character
2. Accept the invitation
Actual Results:  
Response mail does not contain attachments (as the Content-type header has been interpreted as mail body)

Expected Results:  
Response mail is a valid invitation response.
In Lightning 0.9 "calItipEmailTransport.js" line 352 
seems to be a good place to start looking at 
(newline characters should be removed before writing 
user provided strings into a mail header)
Version: unspecified → Lightning 0.9
Attachment #343518 - Attachment mime type: text/calendar → text/plain
Status: UNCONFIRMED → NEW
Depends on: 457203
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
has been fixed with bug 457203
Assignee: nobody → daniel.boelzle
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.