Closed Bug 460440 Opened 12 years ago Closed 12 years ago

need to propagate aInherited parameter for when -moz-transform code calls CalcLength

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.1b2

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
I saw the assertion caused by
NS_POSTCONDITION(!unused, "How did we inherit a value?");
during the style system mochitests, and this led me to the fact that we really do need to propagate that parameter; em units set aInherited to true since computations based on them can't be cached in the rule tree.  (We should probably rename some things in various places to make things clearer...)

This led me to write a test showing the bug this causes (reftest included in patch) and a patch to fix the problem.
Attachment #343538 - Flags: superreview?(bzbarsky)
Attachment #343538 - Flags: review?(keith)
Attachment #343538 - Flags: superreview?(bzbarsky) → superreview+
Comment on attachment 343538 [details] [diff] [review]
patch

There's some indentation weirdness going on here.  Tabs or something?

Also, why put aInherited before the other args in some cases, but all the way at the end in others?  Seems like it'd make more sense to toss it at the end of the arg list for ProcessTranslateX and so forth, so that the data/context/prescontext/inherited order is the same as in rulenode.
Comment on attachment 343538 [details] [diff] [review]
patch

Looks great - thanks for fixing this!  Looks like I misinterpreted what the aInherited value meant during the initial implementation.
Attachment #343538 - Flags: review?(keith) → review+
Fixed:
http://hg.mozilla.org/mozilla-central/rev/0bb27db9264e
Also fixed the tabs from the transforms patch and in one other file:
http://hg.mozilla.org/mozilla-central/rev/b99df03358f2
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
You need to log in before you can comment on or make changes to this bug.