When going to compose and then button address, there are no addresses in window

RESOLVED FIXED in seamonkey2.0

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Joe Adinolf, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0, regression})

Trunk
seamonkey2.0
fixed-seamonkey2.0, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080925121544 SeaMonkey/2.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080925121544 SeaMonkey/2.0a1

This is SM 2.0a1

When using mail and going to Compose and then Address there are no addresses shown in the window. The address you want can be accessed by typing the person's name in the search area.

My address book imported with no problems.

I have installed the program on 2 computers just to be sure. Same result.

Reproducible: Always

Steps to Reproduce:
1.Go to mail
2.Go to compose
3.Go to address
Actual Results:  
No addresses in window

Expected Results:  
Addresses in window

I'm not sure of the correct terminology. When I say window, the description may not be correct but you probably know what I mean.

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081017 SeaMonkey/2.0a2pre

Confirming, on trunk.

When I switched "Look in:" of "Collected Addresses" and back to "Personal Address book" on Select Addresses window - Contacts are displayed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: When going to compose and then s\address, there are no addresses in window → When going to compose and then button address, there are no addresses in window
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
Yes, that works and I noted that the names are jumbled and not in alphabetical order.

Thanks lenochod.

Comment 3

9 years ago
I am also experiencing this problem...can get the addresses by selecting "Collected Addresses" then back to "Personal Address book"

I mentioned this on the moz.support.seamonkey newsgroup and got a response from Hartmut Figge (Mozilla/5.0 (X11; U; Linux i686; rv:1.9.1b3pre) Gecko/20081227
Mnenhy/0.7.5.20005.h1 SeaMonkey/2.0a3pre) so it would seem this is not just a Windows problem.

Comment 4

9 years ago
This isnt a Windows issue its seamonley iisue since it happens on both my Win and Linux boxes.

Ubuntu bug report:
https://bugs.launchpad.net/seamonkey/+bug/327251

Comment 5

9 years ago
This problem has carried over to 2.0b1, and is a little more difficult for me to get my addresses to show.  I have to click back and forth several times to get the addresses to appear.  Needless to say this is a real problem for people like me who use e-mail a lot.

I hope this is going to get someone's attention soon.  In case it matters, I upgraded from 1.1.14.
(Reporter)

Comment 6

9 years ago
At least the names are in alphabetical order which is a big plus.

Comment 7

9 years ago
Yes, but clicking 4 times to get to them, is not very convenient.   ;)
(Assignee)

Comment 8

9 years ago
Created attachment 405356 [details] [diff] [review]
define variable

AFAICS this is SM-only code even though it (still) lives under mailnews/.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #405356 - Flags: superreview?(neil)
Attachment #405356 - Flags: review?(mnyromyr)
(Assignee)

Updated

9 years ago
Keywords: regression
OS: Windows XP → All
Hardware: x86 → All

Comment 9

9 years ago
Comment on attachment 405356 [details] [diff] [review]
define variable

Looks like abList already has the right value, no?
Attachment #405356 - Flags: superreview?(neil) → superreview-
(Assignee)

Comment 10

9 years ago
Created attachment 405360 [details] [diff] [review]
use defined variable [Checkin: Comment 13]
Attachment #405356 - Attachment is obsolete: true
Attachment #405360 - Flags: superreview?(neil)
Attachment #405360 - Flags: review?(mnyromyr)
Attachment #405356 - Flags: review?(mnyromyr)
Comment on attachment 405360 [details] [diff] [review]
use defined variable [Checkin: Comment 13]

As this is address book, Standard8 might be a quicker review.
Attachment #405360 - Flags: superreview?(neil)
Attachment #405360 - Flags: superreview+
Attachment #405360 - Flags: review?(bugzilla)

Updated

9 years ago
Attachment #405360 - Flags: review?(mnyromyr)
Attachment #405360 - Flags: review?(bugzilla)
Attachment #405360 - Flags: review+
Attachment #405360 - Flags: approval-seamonkey2.0+

Comment 12

9 years ago
Comment on attachment 405360 [details] [diff] [review]
use defined variable [Checkin: Comment 13]

Or maybe not. ;-)
(Assignee)

Updated

9 years ago
Keywords: checkin-needed

Comment 13

9 years ago
Comment on attachment 405360 [details] [diff] [review]
use defined variable [Checkin: Comment 13]

http://hg.mozilla.org/comm-central/rev/911c966a0129
Attachment #405360 - Attachment description: use defined variable → use defined variable [Checkin: Comment 13]

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed → fixed-seamonkey2.0
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.