Thunderbird does not start at all. BadWindow (invalid Window parameter)

RESOLVED DUPLICATE of bug 499498

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 499498
10 years ago
9 years ago

People

(Reporter: ray, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Thunderbird 2.0.0.17

The program 'thunderbird-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 2242 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

or..

The program 'thunderbird-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 2199 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


I think this error message is junk. This is not in really related to X. Firefox gets similar errors from time to time, but Thunderbird used to work. Now it does not start, nor does it start after a reboot.

Also one EMail folder was corrupt the last time it started. I think its a Email store problem. Nothing about X. 

This is serious. I changed nothing of my configuration. Thunderbird corrupted the EMail folder and does not even start again. 


Reproducible: Always

Steps to Reproduce:
1. open shell
2. thunderbird
3. crash
Actual Results:  
Guess what.

Expected Results:  
Guess what.

Nobody will read this bug report? Duplicate of #???
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
Please try in a new profile.

Comment 2

10 years ago
the error message comes from gtk, if you don't like it, complain to them.

since you hit this w/ firefox too, sending to core....

btw, your bug report "is junk", per the error message, you must run w/ --sync - you also need a debug build (--enable-debug or --enable-debugger-info-modules and  --disable-strip)
Component: General → Widget: Gtk
Product: Thunderbird → Core
QA Contact: general → gtk
Version: 2.0 → 1.9.0 Branch

Comment 3

9 years ago
I am experiencing this same issue with FF3.5 in both the hg20090617r25988 and rc2 builds (from Ubuntu PPA).  It only happens with one of my profiles, and it happens even if I run with -safe-mode.  I had been using this profile with FF3.5 previously just fine for a couple weeks.  Any suggestions would be appreciated, as I would rather not erase this profile but I do have a backup if necessary.

Comment 4

9 years ago
Okay, this is caused by Compiz/Ubuntu Desktop Effects.  Disabling them allows FF3.5 to start just fine under this profile.  See https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/97492

I'm still not sure what triggered this, however, as that bug is 2.5 years old and I have used FF with compiz for years, including FF3.5 for 2 weeks up until today.

Comment 5

9 years ago
I am no longer seeing this issue with FF3.5.1 nightly build 3.5.1~hg20090629r26036+nobinonly-0ubuntu2~umd1~jaunty.

Comment 6

9 years ago
-> WFM per comment 5.
feel free to change to more appropriate resolution or reopen if needed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 7

9 years ago
Bad news...I just experienced this again with the same nightly build.  I don't know what changed to trigger it!  I quit firefox, tried to restart it, and then nothing.  The strange thing is that if I launch firefox-3.5 with -g for debug, then gdb gets suspended and kicks me to a shell.  When I enter "fg" gdb then segfaults, however Firefox then opens and works normally!  If I don't use -g, I get the BadWindow error.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 499498
You need to log in before you can comment on or make changes to this bug.