Closed Bug 460587 Opened 14 years ago Closed 14 years ago

Ctrl-Tab background is grey on Vista (No Aero Glass effect)

Categories

(Core :: XUL, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.1b2

People

(Reporter: u88484, Assigned: mstange)

References

Details

(Keywords: regression)

Attachments

(2 files)

The background for Ctrl-Tab preview pane is grey and no longer has the aero glass effect.

Not sure when this happened but I'm on the 20081017033517 build.
http://hg.mozilla.org/mozilla-central/rev/8d0e5b53857f
Attached image Screenshot
Summary: Ctrl-Tab background is grey (No Aero Glass) → Ctrl-Tab background is grey (No Aero Glass effect)
I am seeing this as well on the trunk.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081018 Minefield/3.1b2pre ID:20081018033524

WFM, maybe Vista specific
Can you give a screenshot of the XP tab preview?
Interesting.
Summary: Ctrl-Tab background is grey (No Aero Glass effect) → Ctrl-Tab background is grey on Vista (No Aero Glass effect)
We will need to set up a regression range for this, can someone maybe start on that?
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c6fcfc205aca&tochange=ea37481b6803

Looks like a good possibility bug 450944 caused this. 

CCing Markus Stange
It's unlikely that this is caused by bug 450944. It mostly touches Mac-only code, and where it touches cross-platform code (e.g. http://hg.mozilla.org/mozilla-central/diff/fbb71be15c4d/layout/xul/base/src/nsMenuPopupFrame.cpp ) I didn't change any behaviour as far as I can see.

Could somebody confirm this by doing a local backout of changeset fbb71be15c4d? I can't test on Vista.

CCing Rob Arnold, the Vista Glass guy.
(In reply to comment #9)
> http://hg.mozilla.org/mozilla-central/diff/fbb71be15c4d/layout/xul/base/src/nsMenuPopupFrame.cpp

Oops, haha. I'm blind this morning. Taking.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Blocks: 450944
Component: General → XUL
Product: Firefox → Core
QA Contact: general → xptoolkit.widgets
fixed: http://hg.mozilla.org/mozilla-central/rev/b9a8515b4bed

Sorry that I didn't pay attention when I merged.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.