Closed Bug 460623 Opened 11 years ago Closed 10 years ago

Google searches for Firefox could be faster

Categories

(Firefox :: Search, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 511017

People

(Reporter: JuninhoCAEMJ, Unassigned)

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

	
I tried not yet in other languages (English, Spanish, etc ...) but
I discovered that when a person is searching on Google for bar
located on the right from above, the script makes the search with the
following algorithm: (http://www.google.com/search?q=pesquisa) where
research is the subject of research. To improve the polls, not
would be smart to search and are thus: (http://www.google.com.br/
search? q = search)? It seems stupid but by my tests it
make the searches on Google at least a little faster as
IE does. I have already submitted a feedback to mozilla but got no response. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Assignee: nobody → gjalves
Component: Search → pt-BR / Brazilian
Product: Firefox → Mozilla Localizations
QA Contact: search → leandro
Keywords: 4xp, perf
Keywords: 4xp
mconnor has been planning changes to the search service update system that would allow search providers to update the app-shipped engines. Part of the benefits for doing that would be the possibility of serving locale-specific updates such that users would go directly to their localized version of the search engine.
Assignee: gjalves → nobody
Component: pt-BR / Brazilian → Search
Product: Mozilla Localizations → Firefox
QA Contact: leandro → search
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Er, why did you resolve this as FIXED?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(In reply to comment #0)
Unfortunately, localizations are not allowed to provide a localized Google plugin. All people outside US are redirected to local domains.
This originally was done at the request of Google, FWIW.  The problem was that in many cases locale is not a good match for location (i.e. we serve en-GB for English users in .au, hardcoding co.uk is actually far worse for those users).  There's also a very large number of people using en-US builds in different locations that are better served by a different TLD.

We're working on a change for 3.1.
(In reply to comment #4)
> This originally was done at the request of Google, FWIW.  The problem was that
> in many cases locale is not a good match for location (i.e. we serve en-GB for
> English users in .au, hardcoding co.uk is actually far worse for those users). 
> There's also a very large number of people using en-US builds in different
> locations that are better served by a different TLD.
> 
> We're working on a change for 3.1.

Mike, any update on your last comment? Has something been changed for 3.5 in this area?
bug 467890 covers the support in Firefox, I don't know when we'll have a default google search plugin checked in, but that's in progress, if not already done.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511017
You need to log in before you can comment on or make changes to this bug.