Use the right delay with XHR progress events

RESOLVED FIXED

Status

()

Core
DOM
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

({fixed1.9.1})

Trunk
x86
All
fixed1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The spec will probably change so that 350msec delay drops to 50msec.
XHR2 has been updated and it says 50ms.
Flags: blocking1.9.1?
Created attachment 355936 [details] [diff] [review]
patch

A testcase http://mozilla.pettay.fi/xhr_upload/xhr_upload_demo.html
Assignee: nobody → Olli.Pettay
Status: NEW → ASSIGNED
Attachment #355936 - Flags: superreview?(jonas)
Attachment #355936 - Flags: review?(jonas)
Er, this is the test
http://mozilla.pettay.fi/xhr_upload/xhr_upload_demo_timers.html
(which may take *long* time to load because of some JS regression)

I'll check if mochitest can handle such tests nowadays.
Attachment #355936 - Flags: superreview?(jonas)
Attachment #355936 - Flags: superreview+
Attachment #355936 - Flags: review?(jonas)
Attachment #355936 - Flags: review+
Attachment #355936 - Flags: approval1.9.1+
http://hg.mozilla.org/mozilla-central/rev/aeca8558250a

Will commit to 1.9.1 soon.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Flags: blocking1.9.1?
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/cfdfc92e1553
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.