JS jitter degrades in performance with raytrace example from Mark Webster

RESOLVED DUPLICATE of bug 460964

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 460964
9 years ago
9 years ago

People

(Reporter: Reece H. Dunn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081020 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081020 Minefield/3.1b2pre

When pressing the Render button successive times, there is an initial boost in performance when the jitter is triggered for several represses of the Render button (between roughly 1 and 3), after which the jitter starts to take a pathological amount of time to complete - up to 10 times the amount of time from a run without jit enabled, during which FF becomes unresponsive.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Rendering takes successively longer with each run, after the initial increase from the jitter.

Expected Results:  
The rendering should remain quick once the jitter has been triggered.

Comment 1

9 years ago
bz is on the case
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460964
You need to log in before you can comment on or make changes to this bug.