XML and XMLList objects do not implement toSource()

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: hannesw, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: 

XML and XMLList do not currently implement the toSource() method. The inherited toSource() produces a bogus JavaScript object:

x = <x>foo</x>
x.toSource()
({0:{}})


Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 344076 [details] [diff] [review]
Fixes this bug

Implement toSource for XML and XMLList objects.
(Reporter)

Comment 2

10 years ago
Committed patch: 

Checking in xmlimplsrc/org/mozilla/javascript/xmlimpl/XML.java;
/cvsroot/mozilla/js/rhino/xmlimplsrc/org/mozilla/javascript/xmlimpl/XML.java,v  <--  XML.java
new revision: 1.28; previous revision: 1.27
done
Checking in xmlimplsrc/org/mozilla/javascript/xmlimpl/XMLList.java;
/cvsroot/mozilla/js/rhino/xmlimplsrc/org/mozilla/javascript/xmlimpl/XMLList.java,v  <--  XMLList.java
new revision: 1.28; previous revision: 1.27
done
Checking in xmlimplsrc/org/mozilla/javascript/xmlimpl/XMLObjectImpl.java;
/cvsroot/mozilla/js/rhino/xmlimplsrc/org/mozilla/javascript/xmlimpl/XMLObjectImpl.java,v  <--  XMLObjectImpl.java
new revision: 1.24; previous revision: 1.23
done
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Duplicate of this bug: 374047
You need to log in before you can comment on or make changes to this bug.