Closed Bug 461124 Opened 11 years ago Closed 11 years ago

Mode/Tab doesn't change when using Alt+[1234]

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: maxxmozilla)

Details

Attachments

(2 files)

STR:

* Go into mail mode
* Press Alt+1 (or 2,3,4)


Result:

* Title changes to include the view's date range
* No calendar tab is opened


Expected (variant 1):

* Calendar Tab is opened
* Corresponding view is shown

Expected (variant 2):
* No title change
* No calendar tab is opened
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0? → blocking-calendar1.0+
What is the really expected variant ?
I think I would propose #2 and leave only Ctrl+3 to switch to the calendar.

BTW calendar-common-sets.xul:
>  #ifdef XP_MACOSX
>    // The following Mac specific code-lines are necessary, because you can't
mac specific code shouldn't apply also to windows ;)
also this file is not being preprocessed.
Only tested in Sunbird, don't know if this patch fixes the Lightning tab issue too.
Attachment #348837 - Flags: review?(philipp)
Attachment #348837 - Flags: review?(philipp) → review+
Attachment #348837 - Attachment description: enable preprocessing of calendar-common-sets.xul → [checked in] enable preprocessing of calendar-common-sets.xul
Comment on attachment 348837 [details] [diff] [review]
[checked in] enable preprocessing of calendar-common-sets.xul

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/d882e901e3f6>
Keywords: checkin-needed
Attached patch Fix v1Splinter Review
Switching views (alt+1234) works only when in calendar tab

At first I had planned to check if calendar tab is selected but it doesn't have the ID :(
can it be added in the future ?
Assignee: nobody → firefox
Status: NEW → ASSIGNED
Attachment #350367 - Flags: review?(mschroeder)
Attachment #350367 - Flags: review?(mschroeder) → review?(Berend.Cornelius)
Attachment #350367 - Flags: review?(Berend.Cornelius) → review+
Comment on attachment 350367 [details] [diff] [review]
Fix v1

r=berend. I think it's the right way to go to query the "checked" attribute of the command instead of the "selected" attribute of the tab. User interface elements are sort of transient over the time but commands are more likely to persist - that is one reason why we use them.
pushed fix v1 to comm-central:

http://hg.mozilla.org/comm-central/rev/6a5ac370b3a6

I find the issue is fixed.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.