Awesome bar does not appear at all

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: ed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081022 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081022 Minefield/3.1b2pre

The 'awesome bar' does not appear at all.  I can type in the address bar and no suggestions are shown.  Clicking on the down-arrow icon at the right of the address bar has no effect.

I first got this with 3.1 beta 1 and it is still present with the latest nightly build, installed in a fresh directory.

Reproducible: Always

Steps to Reproduce:
1. Click down-arrow next to address bar.
Actual Results:  
Nothing.

Expected Results:  
A list of commonly visited sites should appear.
Are you running any add-ons?  If so, which ones, and have you tried with them disabled?  Also, do you see any exceptions in Tools | Error Console?
(Reporter)

Comment 2

10 years ago
I removed all add-ons except for the English language dictionary and the bar is still missing.  I will check the error console.
(Reporter)

Comment 3

10 years ago
Two lines appear in the error console when I press the down-arrow icon to display the awesome bar:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]

Error: Async statement execution returned with '11', 'cannot start a transaction within a transaction'
Source File: file:///h:/winnt/firefox-nightly/components/nsPlacesDBFlush.js
Line: 170

This is with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081029 Minefield/3.1b2pre.
(Reporter)

Comment 4

10 years ago
The file h:\winnt\firefox-nightly\components\nsPlacesDBFlush.js does exist.

I suspect this problem was caused by installing various versions of Firefox in separate directories: I installed Firefox 3 in H:\winnt\firefox-3, the 3.1 beta in H:\winnt\firefox-3.1, and a nightly build (to test this bug) in H:\winnt\firefox-nightly.

I put them in separate directories exactly so that they would not interfere with each other, but there seems to be some crossed wire somewhere.  I started Firefox from H:\winnt\firefox-3.1 but it wants to upgrade itself each day to the latest nightly build, and it is looking for this file in H:\winnt\firefox-nightly.

Is there something I can do to help reproduce this?  I'm thinking I could delete all installed copies of Firefox, then install both the 3.1 beta and a nightly build in different directories, run both of them and see if the problem recurs.

Comment 5

10 years ago
Shawn, do you know anything about the error above:
Error: Async statement execution returned with '11', 'cannot start a
transaction within a transaction'
Well, that message is totally wrong, but 11 maps to SQLITE_CORRUPT...
(Reporter)

Comment 7

10 years ago
This error went away, but let me know if you want me to do something to help reproduce it.  (I think the root cause is cross-contamination between different Firefox versions, even though I installed them in separate directories.)

Comment 8

10 years ago
simply report back if this happens again.

you could try opening places.sqlite with a third party database manager (firefox must be closed), and execute the following query: "pragma integrity_check;"
it should return OK or an error.

Comment 9

10 years ago
resolving WFM, please reopen if that happens again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.