js1_6/extensions/regress-456826.js: (Math|Date) is not defined

VERIFIED FIXED

Status

()

Core
JavaScript Engine
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: bc, Assigned: Igor Bukanov)

Tracking

(4 keywords)

Trunk
regression, testcase, verified1.9.0.9, verified1.9.1
Points:
---
Bug Flags:
blocking1.9.1 +
blocking1.9.0.9 +
wanted1.9.0.x +
wanted1.8.1.x -
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:investigate] post 1.8-branch)

Attachments

(2 attachments, 1 obsolete attachment)

572 bytes, patch
Igor Bukanov
: review+
Details | Diff | Splinter Review
821 bytes, patch
mrbkap
: review+
Samuel Sidler (old account; do not CC)
: approval1.9.0.9+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
from bug 456826 comment 36.

./js1_6/extensions/regress-456826.js:93: Math is not defined
./js1_6/extensions/regress-456826.js:127: Date is not defined

either of these errors may occur depending on the build and shell options.

this regressed in http://hg.mozilla.org/mozilla-central/rev/62b8f8cd8b69

Igor@mir2.org date: Wed Apr 02 00:46:12 2008 -0700 summary: [Bug 423874] Allocating functions together with JSObject. r=brendan
Flags: in-testsuite+
Flags: in-litmus-

Updated

9 years ago
Assignee: general → igor
Flags: blocking1.9.1+
(Assignee)

Comment 1

9 years ago
The regression is from bug 365851 and comes from the fact that js_FindPropertyHelper, http://hg.mozilla.org/mozilla-central/file/0d837275baca/js/src/jsobj.cpp#l3533 , does not propagate the error condition from js_LookupPropertyWithFlags . The latter returns -1 on errors and the code ignores that.

The reason the failure is associated with the bug 423874 is that bug altered the memory usage for the function objects. Given the restriction gcparam("maxBytes", 22000); from the test, that triggered the failure on the code path with errors.
Blocks: 365851
No longer blocks: 423874
(Assignee)

Comment 2

9 years ago
Created attachment 350229 [details] [diff] [review]
fix v1

The patch just adds the missing error check.
Attachment #350229 - Flags: review?(brendan)
(Assignee)

Comment 3

9 years ago
Note on ./js1_6/extensions/regress-456826.js test: on 64-bit platform it fails with OOM and that should be OK. Alternatively, changing 22000 in gcparam("maxBytes", 22000); to 60000 on 64 bit should make it work.
Attachment #350229 - Flags: review?(brendan)
Attachment #350229 - Flags: review+
Attachment #350229 - Flags: approval1.9.1?
Attachment #350229 - Flags: approval1.9.0.6?
Comment on attachment 350229 [details] [diff] [review]
fix v1

Whoops -- thanks for fixing.

/be

Comment 5

9 years ago
Comment on attachment 350229 [details] [diff] [review]
fix v1

a=sayrer, but it's already blocking
Attachment #350229 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 6

9 years ago
Created attachment 350244 [details] [diff] [review]
fix v1 (mq patch)
Attachment #350229 - Attachment is obsolete: true
Attachment #350244 - Flags: review+
Attachment #350229 - Flags: approval1.9.0.6?
(Assignee)

Updated

9 years ago
Group: core-security
(Assignee)

Comment 7

9 years ago
I marked the bug as restricted as it is not clear if there any hazards due to it.
Pushed http://hg.mozilla.org/mozilla-central/rev/4c6331befc51
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

9 years ago
verified fixed mozilla-central but not tracemonkey
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1
(Reporter)

Comment 10

9 years ago
v 1.9.1, 1.9.2
Keywords: fixed1.9.1 → verified1.9.1
Not needed for 1.8, wanted for 1.9.0 which contains the patch from bug 365851 that caused this. Don't know the potential security impacts of this.
Flags: wanted1.9.0.x+
Flags: wanted1.8.1.x-
Whiteboard: [sg:investigate] post 1.8-branch
Flags: blocking1.9.0.8?
Flags: blocking1.9.0.8? → blocking1.9.0.8+
Flags: blocking1.9.0.8+ → blocking1.9.0.8?
Flags: blocking1.9.0.8? → blocking1.9.0.8+
Igor: Can you please work up a 1.9.0-branch patch for this? Our code freeze for 1.9.0.8 is tomorrow and this blocks the release.
Created attachment 367870 [details] [diff] [review]
Patch for the 1.9.0 branch
Attachment #367870 - Flags: review+
Attachment #367870 - Flags: approval1.9.0.8?
Attachment #367870 - Flags: approval1.9.0.8? → approval1.9.0.8+
Comment on attachment 367870 [details] [diff] [review]
Patch for the 1.9.0 branch

Approved for 1.9.0.8. a=ss for release-drivers
Fixed on the 1.9.0 branch.
Keywords: fixed1.9.0.8
(Reporter)

Comment 16

8 years ago
v 1.9.0
Keywords: fixed1.9.0.8 → verified1.9.0.8
Group: core-security
You need to log in before you can comment on or make changes to this bug.