[EVENTTARG]mouse events not passed through to abs/rel positioning items

NEW
Unassigned

Status

()

P3
normal
18 years ago
9 years ago

People

(Reporter: jackd, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
If <IMG src="xxx" style="position:absolute" onclick="alert('hello')"> is
inserted inside of a <SPAN style="position:relative"></SPAN> tagset, clicking on
the image does not fire the onclick() event.

Comment 1

18 years ago
HTML Element
Assignee: asa → clayton
Component: Browser-General → HTML Element
QA Contact: doronr → petersen
Created attachment 11739 [details]
testcase as described by reporter
The above testcase works fine for me in Linux mozilla 2000-07-21-15-M17.

Reporter:  Please attach (to this bug) a testcase that shows the problem.  If
not, this bug will be marked WORKSFORME.  Also, please say in what build you are
seeing the problem.
Assignee: clayton → joki
Component: HTML Element → Event Handling
QA Contact: petersen → janc
(Reporter)

Comment 4

18 years ago
I am using the M16 build (incl. MathML/SVG) on Windows NT4 SP6, and the testcase
attachment fails.
Just pulled and built on NT and Linux, and can't reproduce using David Baron's
testcase.

However, I did notice a couple of other bugs:

1) When you open the testcase, you will get an assertion that you can (safely?)
ignore.
2) When you click the image in the test case, dismiss the popup and then press
back button, the browser always crashes.

Can you see these too? I do not know if they are new or duplicates, searching...
I will add info here once I find the bugs or create new ones.
I turned on MathML and SVG, and I am building now to test this on NT.
I cannot reproduce this with MathML & SVG enabled. Marking WORKSFORME. If you
can reproduce this with a new build please reopen this bug and add some
information about your computer setup etc. if there is something special in it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 10

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
(Reporter)

Comment 11

18 years ago
I am using Mozilla build 2000091312 with MathML/SVG enabled, and the test case
fails. Clicking on the Mozilla GIF does nothing, when it should display "hello"
in a message box. I got the same result in Netscape 6 PR3, build 2000092908.

In fact, I usually have to reload the test document in order to get the image to
appear.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Created attachment 18323 [details]
Simple and self explanatory testcase.

Comment 13

18 years ago
Well, there are a few issues here.  One is the fact that the onClick is not
being called, the other is that on NT and MacOS builds of 10-29 the thing is
basically not rendering at all. CONFIRMED.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Using Hixie's testcase I can get the "pass" alert box if I click on the area
where the two boxes with text overlap. Clicking anywhere else I do not get the
dialog.

Also, on first load the page is not painted properly. I do not see the text in
the span element (only the tops of the letters). If I move a window over this
content I can see everything properly.

Comment 15

18 years ago
Distant (or maybe not-so-distant) cousin of http://bugzilla.mozilla.org/
show_bug.cgi?id=52421 I think.
Summary: IMG onclick not called when abs/rel positioning used → [EVENTTARG]IMG onclick not called when abs/rel positioning used
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 17

18 years ago
Setting milestone.

This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
(Reporter)

Comment 18

18 years ago
Please re-open this bug...it is critical to our "Math On the Web" component,
MathPage. We use absolute-within-relative positioning to display equations
properly without interrupting line spacing. The onclick method is then used to
show an enlarged version of the equation. This is a critical feature of MathPage.

The attachments both fail to work correctly in Mozilla 0.8.1

Comment 19

18 years ago
QA contact updated
QA Contact: gerardok → madhur
(Reporter)

Comment 20

17 years ago
As the second attached test case shows (#18323), this problem is not limited to
images but to any absolute positioned item within a relative positioning
context. I changed the bug title (summary) to reflect this.

This seems to be a pretty major bug in the event handling mechanism when CSS
positioning is involved. How can something this basic be marked as a 'Future' fix?
I have tested #18323 on Mozilla 0.9.3 on Windows NTSP6.
Summary: [EVENTTARG]IMG onclick not called when abs/rel positioning used → [EVENTTARG]OnClick event not called for abs/rel positioning items
(Reporter)

Comment 21

17 years ago
This problem is still occurring in Netscape 6.2 and Mozilla 0.9.5 Build ID
2001102403 on my Windows NT SP6 system.

I will attach another test case that shows this problem. The onmouseover event
also is not passed through, so it is possible that no mouse events get through
to the positioned items. I have changed the bug title (summary) to reflect this.
Summary: [EVENTTARG]OnClick event not called for abs/rel positioning items → [EVENTTARG]mouse events not passed through to abs/rel positioning items
(Reporter)

Comment 22

17 years ago
Created attachment 57793 [details]
tests onmouseover/onclick events with abs/rel positioned GIFs

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 23

16 years ago
There is no difference between using addEventListener or the element's
attributes (onclick, onmousemove, etc). I'll attach another testcase that might
be clearer.

Comment 24

16 years ago
Created attachment 119961 [details]
Other simple testcase
The testcase in comment 24 has nothing to do with this bug, and is in fact invalid.

Comment 26

15 years ago
.
Assignee: joki → saari
Status: ASSIGNED → NEW
QA Contact: trix → ian

Updated

15 years ago
Keywords: testcase

Comment 27

15 years ago
Testcase from comment #22 tested on Mozilla 1.4 for Linux:

first test: works
second test: works
third test: alert pops up every second click
forth test: works
fifth test: alert pops up sometimes (not deterministic)
*** Bug 252098 has been marked as a duplicate of this bug. ***
*** Bug 276738 has been marked as a duplicate of this bug. ***
Assignee: saari → nobody
QA Contact: ian → events
You need to log in before you can comment on or make changes to this bug.