Closed Bug 461186 Opened 13 years ago Closed 13 years ago

nsTextControlFrame doesn't need to implement nsIPhonetic

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file)

nsTextControlFrame currently implements nsIPhonetic. There's only one caller, and that caller can just as well use nsITextControlFrame. This helps bug 396185 by reducing one more instance of frames implementing XPCOM interfaces.

Asking for review now... I don't care whether it lands in the 1.9.1 cycle or not, but I'd like to push the reviewed patches to a long-lived branch that can be merged in once 1.9.1 branches.
Huh, the attachment didn't attach the first time.
Attachment #344673 - Flags: superreview?(roc)
Attachment #344673 - Flags: review?(roc)
Duplicate of this bug: 385843
Comment on attachment 344673 [details] [diff] [review]
no nsIPhonetic on nsTextControlFrame, rev. 1

I think you should land these patches now.
Attachment #344673 - Flags: superreview?(roc)
Attachment #344673 - Flags: superreview+
Attachment #344673 - Flags: review?(roc)
Attachment #344673 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/1d7dca06447b
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.