Trailing right-floated items go on new lines.

RESOLVED DUPLICATE of bug 50630

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 50630
10 years ago
10 years ago

People

(Reporter: Daniel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.5.30729)

In the webpage I linked, all red border items are right-floated inline with the green border spans. The first example demonstrates two div's and the second example demonstrates two spans.

According the the CSS 2.1 spec, the items should be on the same line as the span. WebKit browsers and Opera do this properly. 
http://www.w3.org/TR/CSS21/visuren.html#float-position

Reproducible: Always

Steps to Reproduce:
Put a right-floated item at the end of non-floated inline items.
Actual Results:  
The right-floated item will get its own line even if there is space for it on the previous line.

Expected Results:  
The right-floated item should be inline with the rest of the items, provided there is enough space.
Fixed on trunk and in 3.1beta1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 50630
You need to log in before you can comment on or make changes to this bug.