Closed Bug 461336 Opened 11 years ago Closed 10 years ago

window.close() not working

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec1.0+)

VERIFIED WORKSFORME
fennec1.0b1
Tracking Status
fennec 1.0+ ---

People

(Reporter: krudtaa, Assigned: Gavin)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 1.0a1.en-US.win32 

In one page I have the following javascript code to open a new window and give focus to it:

win = window.open ("some-filename.php?list=1", "search_window","menubar=0,resizable=1,scrollbars=1,width=500,height=400");
win.focus();

The above also works on Fennec.... at least windows version.

When I click a button in the newly opened window, then some javascript are run in the parent window... which actually works at it should...
But this line fails:

window.close();

Then window is not closed.
Code executes both above and below the window.close() line though.
Tested by inserting an alert("Test") just before the window.close and after it... and both those alert's fired.

I expect Fennec to default open new windows like this in a separate Folder and not actually open a new window, which was happening on my windows beta version.
Then I also REALLY, REALLY hope you guys will honor window.close() ... to actually close the current folder and give focus back to parent window (folder) automatically (even if it is technically not a window anymmore).
At least that seems like a logical solution to me.... 



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Assignee: nobody → gavin.sharp
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-fennec1.0+
Target Milestone: --- → Fennec A3
Can be reproduced on http://www.youtube.com/ - click the question mark next to " Sign in with your Google Account", it opens a new tab. Clicking "close window" in this tab doesn't do anything.
Blocks: abp
tracking-fennec: --- → 1.0+
Flags: blocking-fennec1.0+
Blocks: 499756
Here is an other example for reproducing this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=499756
I can't reproduce this but with current builds, on Mac or the n810. I did find another problem with window.close, though, which I filed as bug 504352.
Status: NEW → RESOLVED
Closed: 10 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
verified wfm
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.