should prefilling Interview form display *all* fields?

VERIFIED INVALID

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
tested using mozilla opt bits in winnt, 2000.07.21.08. please let me know if
this is expected behavior (it doesn't seem like it should be).

1. go to the Interview form (url above).
2. enter prefix, first and last name, 1st address line, city and state.
3. capture the form data (either actively from the Tasks menu item, or by
clicking "save" at the bottom of the page); respond Yes/ok to the confirming
dialog that shows up.
4. verify data in the Stored Form Data dialog (should be name.first, name.last,
name.prefix, home.city, home.state, and home.street.line1 fields).
5. quit and restart the browser.
6. go to the Interview form again (the fields should be blank).
7. select "Prefill Form with Captured Data" from the Tasks > etc menu.
8. the Prefill Form Data dialog appears.

expected: should only see fields for name.first, name.last, name.prefix,
home.city, home.state, and home.street.line1.

result: i see those fields, along with a bunch of other fields namely beginning
with Business., BillTo., ShipTo...

note: if i go to another form to prefill, such as the sample one at
http://www.mozilla.org/wallet/samples/ebay.html, i see only four fields (name,
home.street.line1, home.city and home.state) available --which makes sense since
those were the only data i provided in step 2.
(Assignee)

Comment 1

18 years ago
That's a feature, not a bug.  If the form has a field for billing 
address and you have never saved a billing address, wallet will try to be smart 
and use your shipping address if you previously saved one, or your home address, 
etc.  Since the most common case is that you have simply one address, this 
frees you from having to enter that address more than once -- you can enter it 
and save it on one form as billing address and then notice that it is prefilled 
for you correctly in the shipping address field of another form.

Now you are looking at the interview form which has every possible field name.  
So since you already saved away your home address, and since this form asks for 
many addresses, you will see that wallet tries to prefill all of these 
other addresses with the one address that it knows about.

Of course if you explicitly entered and saved separate addresses for billing and 
shipping, then wallet will use the correct one in each case.  It's only when you  
haven't saved a value for some address, that wallet will try to use some other 
address that you have saved.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

18 years ago
feel free to verify these (or reopen, if still a problem) if i don't get around
to it beforehand. if you do so, pls do remove the verifyme keyword after
verifying a given bug. thx!
Keywords: verifyme
(Reporter)

Comment 3

18 years ago
vrfy
Status: RESOLVED → VERIFIED
Keywords: verifyme

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
You need to log in before you can comment on or make changes to this bug.