favicon does update to icon of redirected page on another domain

RESOLVED DUPLICATE of bug 411966

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 411966
10 years ago
9 years ago

People

(Reporter: Bas Hickendorff, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre

I have a bookmark that links to a google reader page which then redirects me immediately to an unread posting in google reader (that is usually on another domain).

It's happening in minefield:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre

But not in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

It happens in safemode as well.

Reproducible: Always

Steps to Reproduce:
1. Bookmark the google reader "next" link
2. Click on it
3. The favicon changes to the redirected website, instead of keeping google's icon
Actual Results:  
When I click on the bookmark, it gets the favicon of the page it redirects to, in 3.0 it keeps the google favicon, as I would expect from a bookmark to a google service.

Expected Results:  
Keep the old icon, as in 3.0

I can see a reason for doing this, since it might be the always the same page a bookmark is redirecting to, and then you would like to have the icon of that page, but its not correct to do that in this case, and it's really weird to see the icon changing every time.

I'm sorry if this is a duplicate. I looked through quite some favicon bugs, but I can't find one that seems close enough to this issue.

Comment 1

10 years ago
The reason that this is not happening in 3.0 is that bug 411966 meant that redirects were handled incorrectly.

And you are correct in your reasoning for the behaviour (eg bug 411966 comment #47)

I think that I have seen this unusual case mentioned in a comment in another bug but I can't find it for the moment either.

Comment 2

10 years ago
if the bookmark is a direct redirect to another page, is normal that the favicon gets changed.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411966
You need to log in before you can comment on or make changes to this bug.