[BeOS] First start: Firefox window is bigger than screen

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: ad.ek336, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092816 Iceweasel/3.0.3 (Debian-3.0.3-2)
Build Identifier: Mozilla/5.0 (BeOS; U; Haiku BePC; en-US; rv:1.8.1.12) Gecko/20080210 BonEcho/2.0.0.12

Right after installing Haiku to a partition, at the first run of Firefox, it opens a window that is vertically larger than the screen and horizontally smaller than the screen. So it's neither maximized or a small window.
This is plain ugly. It brings in a messy, untidy feeling to Haiku. Firefox should open (at first run) either a maximized window or some small, centered window. Otherwise people trying out Haiku will get a bad impression.

Reproducible: Always

Steps to Reproduce:
1.Reinstall Haiku
2.Open Firefox
Component: Shell Integration → Widget: Gtk
OS: Other → Linux
Product: Firefox → Core
QA Contact: shell.integration → gtk
Component: Widget: Gtk → Widget: BeOS
QA Contact: gtk → beos

Comment 1

10 years ago
doug, did you see such behaviour?
(with zero settings/clean install of FF, i think)

Comment 2

10 years ago
I can confirm this. After first launch it remembers previous window size, so it's just on first start under Haiku. I suspect it might because of hardcoded window tab height, and Haiku has different, but havn't confirmed that.

Comment 3

10 years ago
(In reply to comment #1)
> doug, did you see such behaviour?
> (with zero settings/clean install of FF, i think)
Yes, I did notice this also, but didn't think anything of it.  I have verified this only under Haiku, so I assumed it was due to some odd change in the OS.

Comment 4

8 years ago
Do you still see this problem using the most recent versions of all components (application, plugins and add-ons)?

If you do not, please close the bug with resolution set to WORKSFORME. If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
(Reporter)

Comment 5

8 years ago
ok
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.