Closed Bug 462229 Opened 13 years ago Closed 13 years ago

Cannot edit/delete address from List in Address Book

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: dypark, Assigned: rain1)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: 3.0b1 pre

Once you create a list and add e-mail addresses, you cannot remove or change the list

Reproducible: Always

Steps to Reproduce:
1.create list and add e-mail address
2.attempt to delete or change an address
3.
Actual Results:  
addresses cannot be removed or edited.  Only solution is to delete the list and recreate the list.

Expected Results:  
List should be fully editable with add, delete and update functionality.
confirming with version 3.0a2 (2008072822). Was not able to find a duplicate.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Coming from a Eudora environment, I am a little spoiled.  Not only can't you do the above, but you can't grab the entire list of emails, and copy them and then paste them into another place; i.e. bcc: field to delete or change the one you want.
Confirmed for Windows XP.

Actually the delete does occur, however no dialog box shows up nor is the screen refreshed. Exiting viewing the list (or switching to another list) and  going back to view the list will confirm that the delete has occurred.
Flags: blocking-thunderbird3?
This bug is also reported under 482006.
Duplicate of this bug: 482006
OS: Mac OS X → All
Hardware: PowerPC → All
Version: unspecified → Trunk
Mark, can you process this bug?  I suspect you know what's going on.
Assignee: nobody → bugzilla
(In reply to comment #6)
> Mark, can you process this bug?  I suspect you know what's going on.

Its definitely broken, not quite sure where or why yet.
Assignee: bugzilla → nobody
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Product: Thunderbird → MailNews Core
QA Contact: address-book → address-book
Target Milestone: --- → Thunderbird 3.0rc1
Assignee: nobody → bugzilla
This patch fixes:
- autocomplete not working in the edit list dialog
- you can't click in the middle of the list to edit (allowevents was true in the wrong place)
- click on the card icon should select the email

Still doesn't fix up/down navigation, because I don't seem to be getting the onkeypress on Windows or Linux here. I can't navigate using the up/down keys within the compose address widget either.
Assignee: bugzilla → sid.bugzilla
Status: NEW → ASSIGNED
Attachment #375816 - Flags: review?(bugzilla)
Comment on attachment 375816 [details] [diff] [review]
patch to fix several things

The up/down keys appear to not work here either. On TB 2 they worked inconsistently as well. We can shift that out to another bug if we want to - it doesn't need to block. This patch fixes the mailing list dialog nicely.
Attachment #375816 - Flags: review?(bugzilla) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/3c86616e351f
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 3.0b3
Duplicate of this bug: 491104
You need to log in before you can comment on or make changes to this bug.