Opening tif images causes continuous creation of tabs.

RESOLVED DUPLICATE of bug 218257

Status

()

RESOLVED DUPLICATE of bug 218257
10 years ago
5 years ago

People

(Reporter: egan.mccomb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

If you open a .tif through File>Open, Open With... Firefox or through dragging, the file isn't read and Firefox creates tabs over and over again without end, usually resulting in crashing Firefox (if you race to close the tabs and are able to close all of them, Firefox stops making more).

This happens even when all plugins are disabled.

In my preferences, in the Applications section, tifs are assigned the action "Use Firefox (default)". 

This does not happen with embedded .tif files, which are handled by the Quicktime plugin. It does not seem like Firefox calls the Quicktime plugin when opening external tifs.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox.
2.Do File>Open and open a tif image.
Actual Results:  
Firefox will create around 3 tabs a second, continuously and infinitely. It will eventually crash if you don't intervene.

Expected Results:  
It should either have displayed the image correctly, or have thrown an error message if it was not possible to display.

Quicktime Version: 7.5.5

Comment 1

10 years ago
so. the problem is that it the preferences should be set to Use Plugin, not Use Firefox.

0. Firefox can't handle tifs.
1. so when it encounters a top level tif,
2. it checks its settings which say "ask the os to run some application to handle it"
3. the something is ... firefox.exe.
4. firefox asks the os to run firefox.exe.
5. The OS says, ok, i'll run firefox.exe for you.
6. it does
7. firefox is told "please open this tif",
8. so it makes a new tab,
9. and tries to open the tif.
10. at this point, go to step 1.

there should already be a bug complaining about this.

sadly there's no easy way to fix it.

firefox doesn't have to be called firefox.exe, it could be called minefield.exe or lemonsherbert.exe

firefox could be configured to use lemonsherbert
lemonsherbert could use minefield
minefield could use grapevine
and grapevine could use firefox.

in this pattern, each application knows "i can't handle it, someone else can", and none of them can easily detect that you've made a loop.

tools>options>content
change .tif to "use this plugin"
Whiteboard: DUPEME
(Reporter)

Comment 2

10 years ago
Thank you for the explanation!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218257

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.