Since checkin for bug 97954, it is impossible to build from scratch.

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
10 years ago
10 months ago

People

(Reporter: fredbezies, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b2pre) Gecko/20081029 Firefox/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b2pre) Gecko/20081029 Firefox/3.1b2pre

Simple to reproduce. Grab a new source tarball. Use this .mozconfig :

#
# See http://www.mozilla.org/build/ for build instructions.
#

. $topsrcdir/browser/config/mozconfig

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-fx

# Options for 'configure' (same as command-line options).
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests

When I entered make -f client.mk depend, it stops saying :

make[3]: /home/fred/logs/fox/src/objdir-fx/js/src/config/nsinstall : command not found.



Reproducible: Always

Steps to Reproduce:
1.See details
2.
3.
Actual Results:  
Build process is stopped.

Expected Results:  
Going on and finish make -f client.mk depend step.
(Reporter)

Updated

10 years ago
Depends on: 97954
(Reporter)

Comment 1

10 years ago
Created attachment 345477 [details]
Log of busted build process.
Component: General → Build Config
Product: Firefox → Core
QA Contact: general → build-config
Version: unspecified → Trunk
Attachment #345477 - Attachment mime type: text/x-log → text/plain
The mozconfig you listed and the one in the build log are not the same. You listed a Firefox mozconfig, and the build log is of suite.
(Reporter)

Comment 3

10 years ago
Oups.

Anyway, it broke around the same point. Will post the right log asap.
(Reporter)

Comment 4

10 years ago
Created attachment 345512 [details]
Right log. Sorry !

Firefox build log.
Attachment #345477 - Attachment is obsolete: true
CCing jimb
Blocks: 97954
No longer depends on: 97954
Attachment #345512 - Attachment mime type: text/x-log → text/plain
(Reporter)

Comment 6

10 years ago
A workaround is to copy nsinstall to js/src/config, but build process is broken a little later :

c++ -o js.o -c -I./dist/include/system_wrappers -include /home/fred/logs/fox/src/js/src/config/gcc_hidden.h -DAVMPLUS_UNIX -DAVMPLUS_LINUX -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DEXPORT_JS_API  -DJS_USE_SAFE_ARENA  -I/home/fred/logs/fox/src/js/src -I.  -I./dist/include   -I./dist/include/js -I/home/fred/logs/fox/src/objdir-fx/dist/include/nspr -I/sdk/include -I/home/fred/logs/fox/src/js/src    -fPIC   -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -fstrict-aliasing    -DMOZILLA_CLIENT -include ./mozilla-config.h -Wp,-MD,.deps/js.pp /home/fred/logs/fox/src/js/src/js.cpp
/home/fred/logs/fox/src/js/src/js.cpp: In function ‘JSBool GetLine(JSContext*, char*, FILE*, const char*)’:
/home/fred/logs/fox/src/js/src/js.cpp:163: attention : le format n'est pas une chaîne littérale et pas d'argument de format
/home/fred/logs/fox/src/js/src/js.cpp: In function ‘void my_ErrorReporter(JSContext*, const char*, JSErrorReport*)’:
/home/fred/logs/fox/src/js/src/js.cpp:3408: attention : ignoring return value of ‘size_t fwrite(const void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result
/home/fred/logs/fox/src/js/src/js.cpp: At global scope:
/home/fred/logs/fox/src/js/src/js.cpp:4050: erreur fatale: ouverture du fichier de dépendances .deps/js.pp: Aucun fichier ou dossier de ce type
compilation terminée.
make[3]: *** [js.o] Erreur 1

js.pp is missing.

Is it a gcc 4.3 bug ? An ubuntu linux bug ? I can't say, but it is annoying to say the least :(
(Reporter)

Comment 7

10 years ago
For this another issue, looks like mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-fx
 from my .mozconfig is ignored.

Could be a clue ?!
(Reporter)

Comment 8

10 years ago
Tried another thing, which failed too : using a source tarball I have made before 29 october, ran a make -f client.mk depend - which worked - and then updated source code. Launch it again and it crashes at the same point :

/js/src/config/nsinstall cannot be found !

This is driving me crazy :(
(Reporter)

Comment 9

10 years ago
A workaround which could find why there is a bug here ?!

1) Go to objdir-fx/js/src/
2) make
3) Go to objdir-fx/config/js
4) /usr/bin/make -C ../../js/src install

Then make -f client.mk depend again, it ends the "normal" way.

I don't know if make -f client.mk build will end successfully, at least I have a working workaround.
I'm afraid the burden is on you here. All of the tinderboxes are building just fine, and plenty of other people are building without problems. You'll need to figure out what it is in your build configuration that's causing problems.
(Reporter)

Comment 11

10 years ago
The problem is that it happened on both an old install of Ubuntu Linux 8.10 (installed from beta) and then a brand new install from yesterday.

Stinks like my computer is broken. 

Tried with both gcc 4.3 (main ubuntu one) and 4.2 (another one) version. And each time it broke at the same place.

Could be an ubuntu 64 bits only problem. Anyway, I found a workaround, so I think I will close it as INVALID. Seems like my linux is guilty here.

Sorry for so much bothering.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
I don't think it's invalid, unless you figure out that there's actually something in your environment that is broken. It's more likely that something in your environment is different and causing the build scripts to not work properly, which we should fix.
(Reporter)

Comment 13

10 years ago
It could simple to reproduce : 

1) Install an ubuntu intrepid ibex (AMD64) in a virtual machine.
2) In a console, enter :
sudo aptitude install build-essential libasound2 firefox-dev xulrunner-dev mercurial
sudo aptitude builddep firefox
3) Grab your firefox source code.
4) Build it.
(Reporter)

Comment 14

10 years ago
Created attachment 345925 [details]
English speaking version of crash log.

For package installation, you should read build-dep instead of builddep.

And crash still happening. Could be an ubuntu intrepid ibex related bug. Got this log with a virtual machine (virtualbox 2.0.4) and following step described before. Will try ubuntu intrepid ibex 32 bits asap.
Attachment #345512 - Attachment is obsolete: true
(Reporter)

Comment 15

10 years ago
Modifying some requirements package :

libasound2 -> libasound2-dev

And forgot to add : libogg-dev, libvorbis-dev, libtheora-dev

Oops !
(Reporter)

Comment 16

10 years ago
Crash with ubuntu intrepid ibex 32 bits too in a virtualbox virtual machine. Will attach build log.
(Reporter)

Comment 17

10 years ago
Created attachment 345931 [details]
Intrepid ibex 32 bits build log
(Reporter)

Comment 18

10 years ago
Well it seems to be broken only when using make -f client.mk depend. Using directly make -f client.mk build, all is working right. Weird.

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.