Flash movie content in a previous(another) tab are shown for a moment

VERIFIED FIXED

Status

()

Core
Plug-ins
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: memai, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081030 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081030 Minefield/3.1b2pre

move to another tab while i'm viewing Flash movie content(E.g. YouTube, Dailymotion), Flash movie content in a previous tab are shown for a moment.

Reproducible: Always

Steps to Reproduce:
1.start Minefield
2.load Flash movie content (E.g. http://www.youtube.com/watch?v=eIn37vzO-6g)
3.create a new tab (Ctrl+T)


Actual Results:  
Flash movie content in a previous tab are shown for a moment

Expected Results:  
Flash movie content in a previous tab shouldn't be shown

Works: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081029 Minefield/3.1b2pre
Fails: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081030 Minefield/3.1b2pre
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
Seems that Bug 459530 could have caused this, although the check-in was at Thu Oct 30 10:41:19 and the failing build is 20081030104903. It is also not 100% reproducible, at least not on this Vista system. But we'll see.
Blocks: 459530
Component: General → Plug-ins
Keywords: regression
Product: Firefox → Core
QA Contact: general → plugins
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.1?
The changes made by the patch for bug 459530 were all Mac-specific.  They shouldn't make any difference on other platforms.
(Reporter)

Comment 3

9 years ago
related?  Bug 458928
https://bugzilla.mozilla.org/show_bug.cgi?id=458928#c20
I installed  TabPreview extension now and I see same problem.
(In reply to comment #2)
> The changes made by the patch for bug 459530 were all Mac-specific.  They
> shouldn't make any difference on other platforms.
Yeah, I see it also in an earlier build. But I can press 20 times or more  ctrl+tab without seeing the bug.
No longer blocks: 459530
(In reply to comment #3)
> related?  Bug 458928
> https://bugzilla.mozilla.org/show_bug.cgi?id=458928#c20
> I installed  TabPreview extension now and I see same problem.
Yes, possible and more likely. What I also see when I watch the Windows taskbar buttons is that it attempts to start another window and then changes its mind. That symtom is more clear here.
Blocks: 458928

Comment 6

9 years ago
Definitely.  See my comment: https://bugzilla.mozilla.org/show_bug.cgi?id=458928#c20

I think we're just waiting for approval on the patch to back out the "evil" parts.

Updated

9 years ago
Duplicate of this bug: 462670
Testcase from duped bug: https://bugzilla.mozilla.org/attachment.cgi?id=345867
I'm seeing this problem all the time when switching tabs. This definitely should block 1.9.1.
I checked in a patch for this (see bug 458928). If this is still broken in tonight's nightly build, please reopen. Changeset is 7effbb367e1d.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

9 years ago
now fixed.thanks

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081103 Minefield/3.1b2pre
Status: RESOLVED → VERIFIED

Updated

9 years ago
Flags: blocking1.9.1?
You need to log in before you can comment on or make changes to this bug.