Address Book smart folder builds "Name" field in non-localized way

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: bugzilla-graveyard, Assigned: bugzilla-graveyard)

Tracking

Details

(Assignee)

Description

10 years ago
In AddressBookManager.m, line 99

http://mxr.mozilla.org/mozilla/source/camino/src/bookmarks/AddressBookManager.m#99

    name = [NSString stringWithFormat:@"%@ %@", firstName, lastName];


That's most likely wrong for any language that uses a Familyname Givenname format, like a lot of East Asian languages (Japanese and Chinese come to mind) or, as Smokey pointed out, Hungarian. There are other examples, I'm sure.

Philippe and Eiichi, is this indeed wrong as it's implemented in Camino? Do contacts in the Address Book collection show up with "backwards" names?

Comment 1

10 years ago
Formally, for Japanese at least, the family name is always listed first - bureaucratic listings, company organigrams, business cards, and written text.
Thus 麻生 太郎 (ASO Taro, the current prime minister).

Amusingly, Apple's Address Book.app, on a newly created Jpn profile, lists the firstName field first (unless that thing picks up the pref from the default admin user). (AB > Preferences > General)
What Safari does is following the order as set in Address book.app (if firstName is first in AB.app, firstName will be listed first in Safari, unless the 'company checkbox' is checked).
(In reply to comment #1)
> What Safari does is following the order as set in Address book.app (if
> firstName is first in AB.app, firstName will be listed first in Safari, unless
> the 'company checkbox' is checked).

...unless the card has an order assigned to it via the Card menu, in which case the card's order wins.

/me curses Address Book developers for using "firstName" and "lastName" rather than something useful and direction-agnostic like "familyName" and "personalName" :P
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

10 years ago
I'll fix this when I fix bug 384691, since I'm cleaning up that code anyway.
Assignee: nobody → cl-bugs-new
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Depends on: 384691
FIXED by the checkin for bug 384691.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.