Closed Bug 462838 Opened 11 years ago Closed 11 years ago

Using the 'Status' column in unifinder to sort events/tasks leads to an exception

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: Fallen)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- add the 'Status' column in the unifinder
- use the 'Status' column to sort events/tasks 

RESULT:
=======

- nothing happens
- the error console shows an exception:

Error: uncaught exception: [Exception... "'[JavaScript Error: "isToDo is not defined" {file: "file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/ulb7u3fd.shredder/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm" line: 143}]' when calling method: [nsITreeView::cycleHeader]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: onxblclick :: line 1278"  data: yes]

EXPECTED RESULT:
================

- no exception

REPRODUCIBLE:
=============

- always
Flags: blocking-calendar1.0+
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081120 Calendar/1.0pre (BuildID: 20081120121029).
Andreas, can you check if it's possible for you to reproduce the issue?
Attached patch Fix - v1Splinter Review
I couldn't reproduce, but in any case this should fix it.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #358029 - Flags: review?(Berend.Cornelius)
Whiteboard: [needs review]
Comment on attachment 358029 [details] [diff] [review]
Fix - v1

I could not reproduce the bug either, but your patch is an improvement in any case. r= berend.
Attachment #358029 - Flags: review?(Berend.Cornelius) → review+
Andreas couldn't reproduce either. Please reopen if this problem persists.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/49d1f161ef3f>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs review]
Target Milestone: --- → 1.0
Checked in lightning and sunbird build 20090128, WFM -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.