"ASSERTION: should be executing script" with 388980-1.html

RESOLVED DUPLICATE of bug 466826

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 466826
10 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({assertion, testcase})

Trunk
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Loading layout/reftests/bugs/388980-1.html triggers:

###!!! ASSERTION: should be executing script: 'mContext->fp', file /Users/jruderman/central/dom/src/base/nsJSEnvironment.cpp, line 3318

###!!! ASSERTION: Someone forgot to block scripts: 'aIsSafeToFlush == nsContentUtils::IsSafeToRunScript()', file /Users/jruderman/central/layout/base/nsPresShell.cpp, line 4496

Since I didn't notice this earlier, I'm guessing it's a recent regression.
Do you have a stack? Can you get a regression range. I don't really know anything about the first assertion (other than that it looks unrelated to the second), cc'ing dbaron who added it.
(Reporter)

Comment 2

10 years ago
This is a regression from within the last 30 hours.
(Reporter)

Comment 3

10 years ago
Created attachment 346390 [details]
stack trace
Note: i run into the same assertion on WinXP when i load http://www.infoworld.com/article/08/11/10/46TC-windows-7_1.html (thats the testurl from Bug 464253)
OS: Mac OS X → All
Hardware: PC → All
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466826
You need to log in before you can comment on or make changes to this bug.