"Upgrade" to 3.0.2 offered while running 3.0.3

RESOLVED DUPLICATE of bug 485624

Status

()

RESOLVED DUPLICATE of bug 485624
10 years ago
10 years ago

People

(Reporter: trs80, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12

I'm running 3.0.3, and was just offered an "upgrade" to 3.0.2. I'm a non-administrative user, and Firefox was installed via WPKG - '"Firefox Setup 3.0.3.exe" -ms' being the install command.

Reproducible: Didn't try




I'll attach active-upgrades.xml. Firefox is configured to use a squid proxy - perhaps it needs to be told to cache-bust upgrade.xml requests?
(Reporter)

Comment 1

10 years ago
Created attachment 346401 [details]
active-updates.xml from Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update
Version: unspecified → Trunk
Whiteboard: [DUPEME]
(Reporter)

Comment 2

10 years ago
After Firefox 3.0.5 was installed via WPKG, I started Firefox and was greeted by a "Updating to 3.0.4 via a partial update failed, retrying with a full update" dialog. The only option available was hide, and it's currently downloading 3.0.4 as I type.
(Reporter)

Comment 3

10 years ago
Created attachment 354810 [details]
active-update.xml
Attachment #346401 - Attachment is obsolete: true
(In reply to comment #0)
>...
> I'll attach active-upgrades.xml. Firefox is configured to use a squid proxy -
> perhaps it needs to be told to cache-bust upgrade.xml requests?
Did you try doing this?

After installing but before running Firefox with WPKG is there an active-update.xml either in the installation directory or in:
Local Settings\Application Data\Mozilla\Firefox\Mozilla
Firefox
James, can you please attach the install.log from your Firefox installation directory (typically c:\program files\mozilla firefox\install.log) and answer the questions in comment #4? Thanks
(Reporter)

Comment 6

10 years ago
Created attachment 355276 [details]
install.log from last week
(Reporter)

Comment 7

10 years ago
(In reply to comment #4)
> (In reply to comment #0)
> >...
> > I'll attach active-upgrades.xml. Firefox is configured to use a squid proxy
> > perhaps it needs to be told to cache-bust upgrade.xml requests?
> Did you try doing this?

No - would I just append a ? to app.update.url?

> After installing but before running Firefox with WPKG is there an
> active-update.xml either in the installation directory or in:
> Local Settings\Application Data\Mozilla\Firefox\Mozilla
> Firefox

This will have to wait for the next Firefox update. Today I ran firefox and it finished the "update" to 3.0.4, after a while it did pick up the 3.0.5 update, downloaded it and installed successfully. active-update.xml in Local Settings now just contains <updates xmlns="http://www.mozilla.org/2005/app-update"/> and there's not one in the install directory.
Attachment #355276 - Attachment mime type: text/x-log → text/plain
(In reply to comment #7)
> (In reply to comment #4)
> > (In reply to comment #0)
> > >...
> > > I'll attach active-upgrades.xml. Firefox is configured to use a squid proxy
> > > perhaps it needs to be told to cache-bust upgrade.xml requests?
> > Did you try doing this?
> 
> No - would I just append a ? to app.update.url?
I don't use a squid proxy so I don't know how to configure it.
Looks like a dupe of bug 353804
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353804
You need to log in before you can comment on or make changes to this bug.