Print page shows all SHOWFOR

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: bubonicfred, Unassigned)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre
Build Identifier: 

When the print button on an article is clicked, the resulting page shows all the SHOWFOR of that page.

Reproducible: Always

Steps to Reproduce:
1.Go to an article with SHOWFOR
2.Click 'Print'
3.Look at resulting page
Actual Results:  
Page shows all SHOWFOR for all OSs and versions

Expected Results:  
Only showing SHOWFOR for os and version selected at origanl article page.
Is this a bug or by design?

Comment 2

10 years ago
It should be viewed as a bug; definitely not wanted behavior. 

It doesn't look like printing uses a separate stylesheet. We use javascript and css to hide/show the right text on screen. Is this possible to do for printing as well, or do we need a separate popup-window-for-printing function? Any css/js experts that can advice here? If it's not possible to
Target Milestone: --- → 1.0

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
What do you think of removing the print icon, until this is fixed?

Updated

10 years ago
Target Milestone: 1.0 → 1.1

Comment 4

10 years ago
Not enough info to fix within 1.1.
Target Milestone: 1.1 → Future

Comment 5

10 years ago
Probably for 2.0 since it's a polish bug.

Comment 6

10 years ago
To track how much traffic this feature gets, we can search omniture for tiki-print.php.

For example, the Print button on the profiles article goes to https://support.mozilla.com/tiki-print.php?locale=en-US&page=Profiles

Comment 7

10 years ago
Hehe... So far this month tiki-print.php has gotten 14 views. That's for all articles. And at least 2 or 3 of them are by me. 
I say we just remove the icon. It looks like there's an option for this at <https://support.mozilla.com/tiki-admin.php?locale=en-US&page=wiki>
Anyone have objections to comment 7?

Comment 9

9 years ago
Do we know what happens when you print without using tiki-print.php?
Do you mean by going to any article and just using File-->Print?

Using Print Preview here until I can test on an actual printer; SHOWFOR is honoured. But I don't think that matters. The print is link in articles is almost useless, and we shouldn't offer it until we have it working properly.
+1 for not offering features until they're actually usable :)
Are you saying that when you select File - Print, it does print what is actually shown on screen, but if you click the Print button it doesn't? That sounds to me like something's wrong with the print button (is it calling a separate feature instead of document.print()? if so, why aren't we just fixing that?).

Comment 13

9 years ago
Created attachment 398020 [details]
empty actions box

Removing print causes the actions box to be empty for logged out users on HTC pages which looks very broken.
(In reply to comment #2)
> We use javascript and css to hide/show the right text on screen. Is this
> possible to do for printing as well, or do we need a separate popup-window-
> for-printing function?

Just enclose the copy of their styles with "@media print { ... }" for printing.

CSS 2.1 Specification - 7 Media types
http://www.w3.org/TR/CSS2/media.html
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.