Adding or modifying event throws exception [Error: "cal.itip is undefined" in calTransactionManager.js]

VERIFIED FIXED in 1.0b1

Status

Calendar
Sunbird Only
--
major
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Stefan Sitter, Assigned: dbo)

Tracking

({regression})

Trunk
1.0b1
regression
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081105 Calendar/1.0pre (BuildID: 20081105110610)

Adding/modifying an event throws an exception. The Edit Event dialog will not close.

Error: '[JavaScript Error: "cal.itip is undefined" {file: "file:///E:/sunbird/modules/calUtils.jsm -> file:///E:/sunbird/calendar-js/calTransactionManager.js" line: 158}]' when calling method: [calIOperationListener::onOperationComplete] = NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
Source file: file:///E:/sunbird/modules/calUtils.jsm -> file:///E:/sunbird/calendar-js/calProviderBase.js
Line: 247

Error: '[JavaScript Error: "cal.itip is undefined" {file: "file:///E:/sunbird/modules/calUtils.jsm -> file:///E:/sunbird/calendar-js/calTransactionManager.js" line: 208}]' when calling method: [nsITransaction::doTransaction] = NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
Source file: file:///E:/sunbird/modules/calUtils.jsm -> file:///E:/sunbird/calendar-js/calTransactionManager.js
Line: 69
(Reporter)

Comment 1

9 years ago
Regression range: Works in Sunbird 1.0pre (20081104050504)
                  Fails in Sunbird 1.0pre (20081105034730)

Seems to be regressed by Bug 457203.
Keywords: regression
(Reporter)

Updated

9 years ago
Blocks: 457203
(Assignee)

Updated

9 years ago
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Flags: blocking-calendar1.0+
(Assignee)

Comment 2

9 years ago
Created attachment 346629 [details] [diff] [review]
fix
Attachment #346629 - Flags: review?(philipp)
Comment on attachment 346629 [details] [diff] [review]
fix

r=philipp
Attachment #346629 - Flags: review?(philipp) → review+
(Assignee)

Comment 4

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/b9c5089c11dc>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0

Comment 5

9 years ago
Checked in sunbird build 20081111 -> VERIFIED.
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.